summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2011-01-19 14:57:48 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2011-05-03 16:49:43 +0200
commitaae03570230d37a74b03892021e5dbe24b7739d2 (patch)
tree3b9334e330b41d8ccb7efc51d003a4a0d2db3c36 /configure.ac
parent68c6014ff0a384cde8fb158456804525e9ac653d (diff)
downloadspice-aae03570230d37a74b03892021e5dbe24b7739d2.tar.gz
spice-aae03570230d37a74b03892021e5dbe24b7739d2.tar.xz
spice-aae03570230d37a74b03892021e5dbe24b7739d2.zip
build: require c99
Because we use c99: stdbool.h, inttypes.h, bool, variadic macros, // comments, ...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 430bf839..4b3d59fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,6 +14,10 @@ AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip subdir-objects])
AM_MAINTAINER_MODE
AC_PROG_CC
+AC_PROG_CC_C99
+if test x"$ac_cv_prog_cc_c99" = xno; then
+ AC_MSG_ERROR([C99 compiler is required.])
+fi
AC_PROG_CXX
AC_PROG_INSTALL
AC_CANONICAL_HOST