summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorErlon Cruz <erlon.cruz@br.flextronics.com>2012-01-27 11:38:40 -0200
committerChristophe Fergeau <cfergeau@redhat.com>2012-02-09 15:51:51 +0100
commit9eb0e4b5778689f8e97e85d51608a2f7d4d90189 (patch)
treea11caf292f07310320562c44ac3deb7b0b9f05ea /configure.ac
parent67178944d26a97a6fb73ddf92b7fefdec6a99fd9 (diff)
downloadspice-9eb0e4b5778689f8e97e85d51608a2f7d4d90189.tar.gz
spice-9eb0e4b5778689f8e97e85d51608a2f7d4d90189.tar.xz
spice-9eb0e4b5778689f8e97e85d51608a2f7d4d90189.zip
Fix mandatory -Werror option
Compilation was breaking due to warning errors even when configuring with --enable-werror=no. This patch fix this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0f8ad7df..8cabbd6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -405,7 +405,7 @@ dnl MAYBE_WARN="-Wall -Wno-sign-compare -Werror -Wno-deprecated-declarations"
if test "$red_target" = "windows"; then
MAYBE_WARN="-Wall -Wno-sign-compare -Wno-deprecated-declarations"
else
- MAYBE_WARN="-Wall -Wno-sign-compare -Werror -Wno-deprecated-declarations"
+ MAYBE_WARN="-Wall -Wno-sign-compare -Wno-deprecated-declarations"
fi
AC_ARG_ENABLE(werror,
@@ -419,7 +419,6 @@ else
fi
])
-
# invalidate cached value if MAYBE_WARN has changed
if test "x$spice_cv_warn_maybe" != "x$MAYBE_WARN"; then
unset spice_cv_warn_cflags