summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2010-09-15 15:55:37 +0200
committerAlon Levy <alevy@redhat.com>2010-12-07 13:31:44 +0200
commit7e0a1dfa75d9c967b96929c56dce4cecb7151a85 (patch)
tree4ec0b7cd9442d8353878f10007bf3c3c629dbc9f /configure.ac
parentd99ec6c35b02a64950c4397644a9a81fad1d4492 (diff)
downloadspice-7e0a1dfa75d9c967b96929c56dce4cecb7151a85.tar.gz
spice-7e0a1dfa75d9c967b96929c56dce4cecb7151a85.tar.xz
spice-7e0a1dfa75d9c967b96929c56dce4cecb7151a85.zip
smartcard: configure option --enable-smartcard
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8742fab8..4f3b1182 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,6 +113,16 @@ AC_ARG_ENABLE(opengl,
[ --enable-opengl Enable opengl requirement / support (not recommended)],
[ have_opengl=yes])
AM_CONDITIONAL(SUPPORT_GL, test "x$have_opengl" = "xyes")
+
+have_smartcard=no
+AC_ARG_ENABLE(smartcard,
+[ --enable-smartcard Enable network redirection],
+[ have_smartcard=yes])
+AM_CONDITIONAL(SUPPORT_SMARTCARD, test "x$have_smartcard" = "xyes")
+if test "x$have_smartcard" = "xyes"; then
+ AC_DEFINE(USE_SMARTCARD, [1], [Define if supporting smartcard proxying])
+fi
+
dnl =========================================================================
dnl Check deps
@@ -168,6 +178,16 @@ if test "x$have_tunnel" = "xyes"; then
AC_DEFINE([HAVE_SLIRP], [], [Define if we have slirp])
fi
+if test "x$have_smartcard" = "xyes"; then
+ PKG_CHECK_MODULES(CAC_CARD, cac_card >= 0.0.1)
+ SMARTCARD_LIBS="$CAC_CARD_LIBS"
+ SMARTCARD_CFLAGS="$CAC_CARD_CFLAGS"
+ SPICE_REQUIRES+=" cac_card"
+ AC_SUBST(SMARTCARD_LIBS)
+ AC_SUBST(SMARTCARD_CFLAGS)
+fi
+
+
PKG_CHECK_MODULES(PIXMAN, pixman-1 >= 0.17.7)
AC_SUBST(PIXMAN_CFLAGS)
AC_SUBST(PIXMAN_LIBS)
@@ -422,5 +442,7 @@ echo "
GUI: ${use_gui}
+ Smartcard: ${have_smartcard}
+
Now type 'make' to build $PACKAGE
"