summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2012-10-16 14:45:07 +0200
committerAlon Levy <alevy@redhat.com>2012-10-19 14:15:06 +0200
commit761ce024066a5825bf372dbdb5e728b210d9b28c (patch)
treef0ef07b76f9f6a46fa88dac9f772d15ed90ebf16 /configure.ac
parentcb27e9dad6f25630b95dc7d9acffdb556aeff174 (diff)
downloadspice-761ce024066a5825bf372dbdb5e728b210d9b28c.tar.gz
spice-761ce024066a5825bf372dbdb5e728b210d9b28c.tar.xz
spice-761ce024066a5825bf372dbdb5e728b210d9b28c.zip
add git-version-gen and gitlog-to-changelog
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 12 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 047191d0..51f60394 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,18 +1,18 @@
AC_PREREQ([2.57])
# Making releases:
-# 1. Increment SPICE_MICRO if no interface change has been done
-# 2. Increment SPICE_MINOR and zero SPICE_MICRO if new interfaces have been added,
-# no changes to existing interfaces.
-# 3. Increment SPICE_MAJOR and zero both SPICE_MINOR and SPICE_MICRO if non
-# backward compatible changes (interface changed or removed).
-#
-# Then change the libtool versions according to libtool manual:
+# 1. The version is SPICE_MAJOR.SPICE_MINOR.SPICE_MICRO
+# 2. It is generated via a two stage process:
+# 1. Create a tag
+# 2. run configure which calls git-version-gen.
+# 3. Follow these rules for setting the next tag (aka tarball version):
+# 1. SPICE_MAJOR remains 0 until a major change is done.
+# 2. Increment SPICE_MINOR to next even value on a significant release,
+# updating the release schedule: http://www.spice-space.org/page/Releases
+# 3. Increment SPICE_MINOR otherwise.
+# 4. Follow the libtool manual for the so version:
# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
-m4_define([SPICE_MAJOR], 0)
-m4_define([SPICE_MINOR], 12)
-m4_define([SPICE_MICRO], 0)
m4_define([SPICE_CURRENT], [6])
m4_define([SPICE_REVISION], [0])
m4_define([SPICE_AGE], [5])
@@ -22,7 +22,8 @@ m4_define([SPICE_AGE], [5])
#
# libspice-servver.so.current-age.age.revision
-AC_INIT(spice, [SPICE_MAJOR.SPICE_MINOR.SPICE_MICRO], [], spice)
+AC_INIT(spice, [m4_esyscmd(build-aux/git-version-gen .tarball-version)],
+ [spice-devel@lists.freedesktop.org], spice)
AC_CONFIG_MACRO_DIR([m4])
AM_CONFIG_HEADER([config.h])