summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2012-06-12 14:15:07 +0300
committerAlon Levy <alevy@redhat.com>2012-06-12 17:55:28 +0300
commit5cbffe794f156814bc1082b2a887ce6d62e87532 (patch)
treef770169ab4c8daa6fce273c9e0fb5d1cf9d51867 /configure.ac
parent2465a8d801cdae183e6b7e85e53a9daa4807f7e6 (diff)
downloadspice-5cbffe794f156814bc1082b2a887ce6d62e87532.tar.gz
spice-5cbffe794f156814bc1082b2a887ce6d62e87532.tar.xz
spice-5cbffe794f156814bc1082b2a887ce6d62e87532.zip
Release 0.11.00.11.0
Current bumped and age bumped for new intefaces only (no backward incompatible changes). New libtool version is 2.0.1, using --version-info instead of --version-name. Doing the version change and --version-name to --version-info change here to avoid changing the libtool version twice. Added interfaces: spice_server_set_name spice_server_set_uuid spice_server_set_listen_socket_fd spice_server_is_server_mouse New library name in linux: libspice-server.so.1.1.0 Old: libspice-server.so.1.0.2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 21 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 66f9d12b..aee29755 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,8 +1,26 @@
AC_PREREQ([2.57])
+# Making releases:
+# 1. Increment SPICE_MICRO if no interface change has been done
+# 2. Increment SPICE_MINOR and zero SPICE_MICRO if new interfaces have been added,
+# no changes to existing interfaces.
+# 3. Increment SPICE_MAJOR and zero both SPICE_MINOR and SPICE_MICRO if non
+# backward compatible changes (interface changed or removed).
+#
+# Then change the libtool versions according to libtool manual:
+# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
+
m4_define([SPICE_MAJOR], 0)
-m4_define([SPICE_MINOR], 10)
-m4_define([SPICE_MICRO], 1)
+m4_define([SPICE_MINOR], 11)
+m4_define([SPICE_MICRO], 0)
+m4_define([SPICE_CURRENT], [2])
+m4_define([SPICE_REVISION], [0])
+m4_define([SPICE_AGE], [1])
+
+# Note on the library name on linux (SONAME) produced by libtool (for reference, gleaned
+# from looking at libtool 2.4.2)
+#
+# libspice-servver.so.current-age.age.revision
AC_INIT(spice, [SPICE_MAJOR.SPICE_MINOR.SPICE_MICRO], [], spice)
@@ -33,7 +51,7 @@ AC_FUNC_ALLOCA
AC_DEFINE([__STDC_FORMAT_MACROS],[],[Force definition of format macros for C++])
-SPICE_LT_VERSION=m4_format("%d:%d:%d", 1, 0, 2)
+SPICE_LT_VERSION=m4_format("%d:%d:%d", SPICE_CURRENT, SPICE_REVISION, SPICE_AGE)
AC_SUBST(SPICE_LT_VERSION)
# Check for the CPU we are using