summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2012-11-23 16:41:48 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2012-12-12 18:15:48 +0100
commit55495a61bfd58332f6c8c0074d51b1bc649df5fa (patch)
treec333d4b2b80c96a054b3b666c22c4b2cf134138f /configure.ac
parent7fe6b6303b83655d8975d72c65eec48024e90761 (diff)
downloadspice-55495a61bfd58332f6c8c0074d51b1bc649df5fa.tar.gz
spice-55495a61bfd58332f6c8c0074d51b1bc649df5fa.tar.xz
spice-55495a61bfd58332f6c8c0074d51b1bc649df5fa.zip
build: Use glib2
Now that QEMU depends on glib, it won't really hurt if we depend on it as well, and we won't have to reinvent our own helpers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a12e1198..fc0216fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -238,6 +238,9 @@ if test "x$enable_smartcard" = "xyes"; then
fi
+PKG_CHECK_MODULES([GLIB2], [glib-2.0 >= 2.22])
+SPICE_REQUIRES+=" glib-2.0 >= 2.22"
+
PKG_CHECK_MODULES(PIXMAN, pixman-1 >= 0.17.7)
AC_SUBST(PIXMAN_CFLAGS)
AC_SUBST(PIXMAN_LIBS)