summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFabiano FidĂȘncio <fabiano@fidencio.org>2012-02-03 02:10:03 -0200
committerAlon Levy <alevy@redhat.com>2012-02-14 14:53:44 +0200
commit1e8e2f9ee082ea0fb0e71736ba6d2578dea05e70 (patch)
tree99c508b51b3e3305ee50b1f5ce5c5f442897cf05 /configure.ac
parentaebe837d3ae58f7bbd48bcb010680c1b95f8dc6a (diff)
downloadspice-1e8e2f9ee082ea0fb0e71736ba6d2578dea05e70.tar.gz
spice-1e8e2f9ee082ea0fb0e71736ba6d2578dea05e70.tar.xz
spice-1e8e2f9ee082ea0fb0e71736ba6d2578dea05e70.zip
Adding support to automated tests
As suggested by Alon, a simple automated test to try to find regressions in Spice code. To use this, compile Spice with --enable-automated-tests and run test_display_streaming passing --automated-tests as parameter.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8cabbd6b..1c15e745 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,6 +129,13 @@ AC_ARG_ENABLE(client,
AS_IF([test x"$enable_client" != "xno"], [enable_client="yes"])
AM_CONDITIONAL(SUPPORT_CLIENT, test "x$enable_client" = "xyes")
+AC_ARG_ENABLE(automated_tests,
+[ --enable-automated-tests Enable automated tests using snappy (part of spice--gtk)],,
+[enable_automated_tests="no"])
+AS_IF([test x"$enable_automated_tests" != "xno"], [enable_automated_tests="yes"])
+AM_CONDITIONAL(SUPPORT_AUTOMATED_TESTS, test "x$enable_automated_tests" != "xno")
+
+
dnl =========================================================================
dnl Check deps
@@ -372,6 +379,16 @@ AM_CONDITIONAL([HAVE_SASL], [test "x$with_sasl2" = "xyes" || test "x$with_sasl"
AC_SUBST([SASL_CFLAGS])
AC_SUBST([SASL_LIBS])
+if test "x$enable_automated_tests" = "xyes"; then
+ AC_MSG_CHECKING([for snappy])
+ snappy --help >/dev/null 2>&1
+ if test $? -ne 0 ; then
+ AC_MSG_RESULT([not found])
+ AC_MSG_ERROR([snappy was not found, this module is part of spice-gtk andis required to compile this package])
+ fi
+ AC_MSG_RESULT([found])
+fi
+
dnl ===========================================================================
dnl check compiler flags
@@ -549,6 +566,8 @@ echo "
Smartcard: ${enable_smartcard}
SASL support: ${enable_sasl}
+
+ Automated tests: ${enable_automated_tests}
"
if test $os_win32 == "yes" ; then