summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2010-12-06 17:59:09 +0200
committerAlon Levy <alevy@redhat.com>2010-12-08 17:13:52 +0200
commit1bb1bcb9a0e369b9663951d9ec944f31984ffdf7 (patch)
treec5b761d2be14d8993ff42a76ba75c2973018743b /configure.ac
parent0449d0520c1173ca70eaf011f69de6123e5c2a48 (diff)
downloadspice-1bb1bcb9a0e369b9663951d9ec944f31984ffdf7.tar.gz
spice-1bb1bcb9a0e369b9663951d9ec944f31984ffdf7.tar.xz
spice-1bb1bcb9a0e369b9663951d9ec944f31984ffdf7.zip
mingw32 build: check for CXImage, disable if not found (only on mingw32)
v2: + simplify (Hans) + also report presence of cximage for mingw32 target
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 36 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e92d7d8f..5b20e5b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -378,6 +378,33 @@ AC_CACHE_CHECK([for supported warning flags], spice_cv_warn_cflags, [
WARN_CFLAGS="$spice_cv_warn_cflags"
SPICE_CFLAGS="$SPICE_CFLAGS $WARN_CFLAGS"
+# use ximage.h for win32 build if it is found (no package for mingw32 atm)
+if test $os_win32 == "yes" ; then
+ AC_MSG_CHECKING([for cximage])
+ AC_TRY_CPP(
+[#include <ximage.h>
+int main()
+{
+ return CXIMAGE_FORMAT_RAW;
+)}
+],[
+ AC_MSG_RESULT([found])
+ have_cximage="yes"
+]
+,[AC_MSG_RESULT([missing])
+ CXIMAGE_CFLAGS='-DDISABLE_CXIMAGE'
+ have_cximage="no"
+ ]
+)
+fi
+AC_SUBST(CXIMAGE_CFLAGS)
+
+# check for windres for mingw32 builds
+if test $os_win32 == "yes" ; then
+ AC_CHECK_PROGS(WINDRES,i686-pc-mingw32-windres mingw-windres mingw32-windres,false)
+ AC_SUBST(WINDRES)
+fi
+
# We only wish to enable attribute(warn_unused_result) if we can prevent
# gcc from generating thousands of warnings about the misapplication of the
# attribute to void functions and variables.
@@ -459,6 +486,14 @@ echo "
GUI: ${use_gui}
Smartcard: ${have_smartcard}
+"
+
+if test $os_win32 == "yes" ; then
+echo \
+" Copy & Paste Images: ${have_cximage}
+"
+fi
- Now type 'make' to build $PACKAGE
+echo \
+" Now type 'make' to build $PACKAGE
"