summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dpmcgee@gmail.com>2012-01-19 14:10:04 -0600
committerAlon Levy <alevy@redhat.com>2012-01-23 12:28:59 +0200
commit07b8d85cb626134d6a2cbcd9f8d0411afdeedaf4 (patch)
tree445827488b357337428409a02bb60633310acc52 /configure.ac
parent90d612686901254ec0d600ea991e65dbdc849ce5 (diff)
downloadspice-07b8d85cb626134d6a2cbcd9f8d0411afdeedaf4.tar.gz
spice-07b8d85cb626134d6a2cbcd9f8d0411afdeedaf4.tar.xz
spice-07b8d85cb626134d6a2cbcd9f8d0411afdeedaf4.zip
Use found python binary to check for pyparsing
This matches what we do in client/Makefile.am to actually run the python scripts, which is to use the python binary we find first, preferring 'python2' over 'python'. This makes the compile work on odd systems such as Arch Linux where the python binary is actually python3. Signed-off-by: Dan McGee <dpmcgee@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index da600177..b6fb7512 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,7 +217,7 @@ SPICE_REQUIRES+=" celt051 >= 0.5.1.1"
if test ! -e client/generated_marshallers.cpp; then
AC_MSG_CHECKING([for pyparsing python module])
-echo "import pyparsing" | python - >/dev/null 2>&1
+echo "import pyparsing" | ${PYTHON} - >/dev/null 2>&1
if test $? -ne 0 ; then
AC_MSG_RESULT([not found])
AC_MSG_ERROR([pyparsing python module is required to compile this package])
@@ -531,6 +531,7 @@ echo "
prefix: ${prefix}
c compiler: ${CC}
c++ compiler: ${CXX}
+ python: ${PYTHON}
Build Spice client: ${enable_client}