summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArnon Gilboa <agilboa@redhat.com>2009-11-26 13:22:27 +0200
committerAlon Levy <alevy@redhat.com>2011-11-14 15:10:23 +0200
commitcc71891a02dea95f2a65c943c634d3a043c9c394 (patch)
treeaf94dea8b217bed813d87a20dc93e66f5c0d95d6 /configure.ac
parentc47bb16e9025ad3e427d480146d150acc9996063 (diff)
downloadspice-cc71891a02dea95f2a65c943c634d3a043c9c394.tar.gz
spice-cc71891a02dea95f2a65c943c634d3a043c9c394.tar.xz
spice-cc71891a02dea95f2a65c943c634d3a043c9c394.zip
client: add xinerama support
RHEL-6 Bugzilla: 695323 cherry-picked from qspice commit 003667ac99beeec9b330a07bc3569c59a96d4588 which fixes RHEL-5 541566 with merge of the one line qspice fix to SPICE_REQUIRES: 9f3fe4755f11044a45c4b21148466a997fcbf735 spice: fixed reference to xinerama pkg config file (Xinerama.pc=>xinerama.pc) Author: Yonit Halperin <yhalperi@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 646cbe7a..861e9396 100644
--- a/configure.ac
+++ b/configure.ac
@@ -283,6 +283,19 @@ if test "$red_target" = "x11"; then
AC_SUBST(MISC_X_LIBS)
fi
+PKG_CHECK_MODULES(XINERAMA,
+ xinerama >= 1.0,
+ have_xinerama=yes,
+ have_xinerama=no)
+
+AM_CONDITIONAL([HAVE_XINERAMA], [test "x$have_xinerama" = "xyes"])
+if test "x$have_xinerama" = "xyes" ; then
+ AC_DEFINE([HAVE_XINERAMA], [], [Define if we have Xinerama])
+ AC_SUBST(XINERAMA_CFLAGS)
+ AC_SUBST(XINERAMA_LIBS)
+ SPICE_REQUIRES+=" xinerama"
+fi
+
# Add parameter for (partial) static linkage of spice client.
# this is used to achive single binary package for all (?) distros.
AC_ARG_ENABLE(static-linkage,
@@ -523,6 +536,8 @@ echo "
Have XRANDR 1.2: ${have_xrandr12}
+ Have Xinerama: ${have_xinerama}
+
Support tunneling: ${enable_tunnel}
Red target: ${red_target}