summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-01-13 20:01:42 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-01-20 12:18:15 +0100
commit7095563153af0e3481605eb5979ca8e6982d95cc (patch)
tree94c8deb74a74571478755ed75c079ba4f1724d10 /configure.ac
parent2ea58dd7a7ec2952e85814ead55d1694584aa471 (diff)
downloadspice-7095563153af0e3481605eb5979ca8e6982d95cc.tar.gz
spice-7095563153af0e3481605eb5979ca8e6982d95cc.tar.xz
spice-7095563153af0e3481605eb5979ca8e6982d95cc.zip
Add reference manual
This manual documents how to enable/use various SPICE features when creating a VM by running QEMU directly, or when using libvirt, or when using virt-manager. This is based on work by Lubos Kocman
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c897368a..aaa7ffc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -415,6 +415,23 @@ if test "x$enable_automated_tests" = "xyes"; then
AC_MSG_RESULT([found])
fi
+
+AC_ARG_ENABLE([manual],
+ AS_HELP_STRING([--enable-manual=@<:@auto/yes/no@:>@],
+ [Build SPICE manual]),
+ [],
+ [enable_manual="auto"])
+if test "x$enable_manual" != "xno"; then
+ AC_PATH_PROG([XMLTO], [xmlto])
+ AS_IF([test -z "$XMLTO" && test "x$enable_manual" = "xyes"],
+ [AC_MSG_ERROR([xmlto is missing and build of manual was requested])]
+ [have_xmlto = no]
+ )
+fi
+AS_IF([test -n "$XMLTO"], [have_xmlto=yes], [have_xmlto=no])
+AM_CONDITIONAL([BUILD_MANUAL], [test -n "$XMLTO"])
+
+
dnl ===========================================================================
dnl check compiler flags
@@ -495,6 +512,8 @@ spice-server.pc
server/Makefile
server/tests/Makefile
client/Makefile
+docs/Makefile
+docs/manual/Makefile
])
dnl ==========================================================================
@@ -525,6 +544,8 @@ echo "
SASL support: ${enable_sasl}
Automated tests: ${enable_automated_tests}
+
+ Manual: ${have_xmlto}
"
if test $os_win32 == "yes" ; then