summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-11-21 11:01:17 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-12-03 11:31:17 +0100
commit1876971442ef808b5dcdaa5dc12df617f2179cb5 (patch)
tree54cdeb35593396e8319ae079f900a18808fb201a /configure.ac
parentb532ef0866cefe260ad0f08550f7c40d3580d0d7 (diff)
downloadspice-1876971442ef808b5dcdaa5dc12df617f2179cb5.tar.gz
spice-1876971442ef808b5dcdaa5dc12df617f2179cb5.tar.xz
spice-1876971442ef808b5dcdaa5dc12df617f2179cb5.zip
client: Remove client code
The client has been superseded by virt-viewer ( http://virt-manager.org/download/sources/virt-viewer/ ) and is no longer being maintained.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac205
1 files changed, 1 insertions, 204 deletions
diff --git a/configure.ac b/configure.ac
index 7545ba05..4e57ef3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,9 +32,6 @@ AC_CONFIG_MACRO_DIR([m4])
AM_CONFIG_HEADER([config.h])
AC_CONFIG_AUX_DIR(.)
-# For automake >= 1.12
-m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
-
AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip subdir-objects])
AM_MAINTAINER_MODE
@@ -43,7 +40,6 @@ AC_PROG_CC_C99
if test x"$ac_cv_prog_cc_c99" = xno; then
AC_MSG_ERROR([C99 compiler is required.])
fi
-AC_PROG_CXX
AC_PROG_INSTALL
AC_CANONICAL_HOST
AC_PROG_LIBTOOL
@@ -57,8 +53,6 @@ AC_CHECK_HEADERS([execinfo.h])
AC_CHECK_HEADERS([linux/sockios.h])
AC_FUNC_ALLOCA
-AC_DEFINE([__STDC_FORMAT_MACROS],[],[Force definition of format macros for C++])
-
SPICE_LT_VERSION=m4_format("%d:%d:%d", SPICE_CURRENT, SPICE_REVISION, SPICE_AGE)
AC_SUBST(SPICE_LT_VERSION)
@@ -84,54 +78,8 @@ esac
AC_MSG_RESULT($variant bit)
AM_CONDITIONAL([X86_64], [test "$variant" = 64])
-AC_MSG_CHECKING([for native Win32])
-case "$host" in
- *-*-mingw*)
- os_win32=yes
- ;;
- *)
- os_win32=no
- ;;
-esac
-AC_MSG_RESULT([$os_win32])
-
-case $host in
- *-*-linux*)
- os_linux=yes
- ;;
-esac
-
-dnl =========================================================================
-dnl Check OS target
-
-AC_MSG_CHECKING([for some Win32 platform])
-case "$host" in
- *-*-mingw*|*-*-cygwin*)
- platform_win32=yes
- ;;
- *)
- platform_win32=no
- ;;
-esac
-AC_MSG_RESULT([$platform_win32])
-if test "$platform_win32" = yes; then
- red_target=windows
-else
- red_target=x11
-fi
-
-AM_CONDITIONAL(OS_WIN32, test "$os_win32" = "yes")
-AM_CONDITIONAL(OS_UNIX, test "$os_win32" != "yes")
-AM_CONDITIONAL(OS_LINUX, test "$os_linux" = "yes")
-
dnl =========================================================================
dnl Check optional features
-AC_ARG_ENABLE(gui,
-[ --enable-gui Enable start dialog with CEGUI],,
-[enable_gui="no"])
-AS_IF([test x"$enable_gui" != "xno"], [enable_gui="yes"])
-AM_CONDITIONAL(SUPPORT_GUI, test "x$enable_gui" != "xno")
-
AC_ARG_ENABLE(opengl,
[ --enable-opengl Enable opengl requirement / support (not recommended)],,
[enable_opengl="no"])
@@ -153,12 +101,6 @@ if test "x$enable_smartcard" = "xyes"; then
AC_DEFINE([USE_SMARTCARD], [1], [Define if supporting smartcard proxying])
fi
-AC_ARG_ENABLE(client,
-[ --enable-client Enable spice client],,
-[enable_client="no"])
-AS_IF([test x"$enable_client" != "xno"], [enable_client="yes"])
-AM_CONDITIONAL(SUPPORT_CLIENT, test "x$enable_client" = "xyes")
-
AC_ARG_ENABLE(automated_tests,
[ --enable-automated-tests Enable automated tests using spicy-screenshot (part of spice--gtk)],,
[enable_automated_tests="no"])
@@ -182,49 +124,10 @@ AC_CHECK_LIB(rt, clock_gettime,
)
AC_SUBST(LIBRT)
-if test "$red_target" = "windows"; then
- AS_VAR_APPEND([SPICE_NONPKGCONFIG_LIBS], [" -lpthreadGC2 -lversion -lmsimg32 $LIBM"])
-else
- AS_VAR_APPEND([SPICE_NONPKGCONFIG_LIBS], [" -pthread $LIBM $LIBRT"])
-fi
-
-dnl The client needs a yield function
-AC_MSG_CHECKING(for posix yield function)
-for yield_func in pthread_yield pthread_yield_np sched_yield \
- thr_yield; do
- spice_save_CPPFLAGS="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS $SPICE_NONPKGCONFIG_LIBS"
- AC_TRY_LINK([#include <pthread.h>],
- [$yield_func()],
- [posix_yield_func="$yield_func"
- break])
- CPPFLAGS="$spice_save_CPPFLAGS"
-done
-if test x"$posix_yield_func" = xnone; then
- AC_MSG_ERROR([No posix yield function found])
-else
- AC_MSG_RESULT($posix_yield_func)
- posix_yield_func="$posix_yield_func()"
-fi
-AC_DEFINE_UNQUOTED([POSIX_YIELD_FUNC],$posix_yield_func,[The POSIX RT yield function])
+AS_VAR_APPEND([SPICE_NONPKGCONFIG_LIBS], [" -pthread $LIBM $LIBRT"])
SPICE_REQUIRES=""
-if test "x$enable_gui" = "xyes" && test "x$enable_client" = "xyes" ; then
- PKG_CHECK_MODULES(CEGUI06, CEGUI-0.6 >= 0.6.0 CEGUI-0.6 < 0.7.0,
- [
- AC_SUBST(CEGUI06_CFLAGS)
- AC_SUBST(CEGUI06_LIBS)
- AC_DEFINE([USE_GUI], [1], [Define to build with CEGUI support])
- ],
- [
- PKG_CHECK_MODULES(CEGUI, CEGUI >= 0.6.0 CEGUI < 0.7.0)
- AC_SUBST(CEGUI_CFLAGS)
- AC_SUBST(CEGUI_LIBS)
- AC_DEFINE([USE_GUI], [1], [Define to build with CEGUI support])
- ])
-fi
-
if test "x$enable_smartcard" = "xyes"; then
PKG_CHECK_MODULES(CAC_CARD, libcacard >= 0.1.2)
SMARTCARD_LIBS="$CAC_CARD_LIBS"
@@ -288,11 +191,6 @@ AC_SUBST(GL_CFLAGS)
AC_SUBST(GL_LIBS)
AS_VAR_APPEND([SPICE_NONPKGCONFIG_LIBS], [" $GL_LIBS"])
-# Add parameter for libXinerama
-AC_ARG_ENABLE([xinerama],
- [AS_HELP_STRING([--disable-xinerama],
- [disable Xinerama library @<:@default=no@:>@])])
-
if test "x$enable_lz4" = "xyes"; then
PKG_CHECK_MODULES(LZ4, liblz4)
AC_DEFINE([USE_LZ4], [1], [Define to build with Lz4 support])
@@ -300,62 +198,6 @@ fi
AC_SUBST(LZ4_CFLAGS)
AC_SUBST(LZ4_LIBS)
-if test "x$red_target" = "xx11" && test "x$enable_client" = "xyes" ; then
- if test "$os_linux" = yes; then
- PKG_CHECK_MODULES(ALSA, alsa)
- AC_SUBST(ALSA_CFLAGS)
- AC_SUBST(ALSA_LIBS)
- fi
-
- PKG_CHECK_MODULES(XRANDR, xrandr)
- PKG_CHECK_MODULES(XFIXES, xfixes)
- PKG_CHECK_MODULES(MISC_X, x11 xext xrender)
- AC_SUBST(XRANDR_CFLAGS)
- AC_SUBST(XRANDR_LIBS)
- AC_SUBST(MISC_X_CFLAGS)
- AC_SUBST(MISC_X_LIBS)
-
- PKG_CHECK_MODULES(XRANDR12,
- xrandr >= 1.2,
- have_xrandr12=yes,
- have_xrandr12=no)
-
- if test "x$enable_xinerama" != "xno"; then
- PKG_CHECK_MODULES(XINERAMA,
- xinerama >= 1.0,
- have_xinerama=yes,
- have_xinerama=no)
- else
- have_xinerama=no
- fi
- if test "x$enable_xinerama" = "xyes" && test "x$have_xinerama" = "xno"; then
- AC_MSG_ERROR([Requested Xinerama library was not found])
- fi
-else
- have_xrandr12=no
- have_xinerama=no
-fi
-
-AM_CONDITIONAL([HAVE_XRANDR12], [test "x$have_xrandr12" = "xyes"])
-if test "x$have_xrandr12" = "xyes" ; then
- AC_DEFINE([HAVE_XRANDR12], [], [Define if we have XRANDR 12])
-fi
-
-AM_CONDITIONAL([HAVE_XINERAMA], [test "x$have_xinerama" = "xyes"])
-if test "x$have_xinerama" = "xyes" ; then
- AC_DEFINE([HAVE_XINERAMA], [], [Define if we have Xinerama])
- AC_SUBST(XINERAMA_CFLAGS)
- AC_SUBST(XINERAMA_LIBS)
-fi
-
-# Add parameter for (partial) static linkage of spice client.
-# this is used to achive single binary package for all (?) distros.
-AC_ARG_ENABLE(static-linkage,
-[ --enable-static-linkage will generate spice client binary with static linkage to external libraries ],,
-[enable_static_linkage="no"])
-AS_IF([test x"$enable_static_linkage" != "xno"],
-[SPICEC_STATIC_LINKAGE_BSTATIC=["-Wl,-Bstatic"]])
-
AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
AC_MSG_CHECKING([for jpeglib.h])
AC_TRY_CPP(
@@ -461,35 +303,7 @@ SPICE_COMPILE_WARNINGS
LIBVIRT_LINKER_RELRO
LIBVIRT_LINKER_NO_INDIRECT
-# use ximage.h for win32 build if it is found (no package for mingw32 atm)
-if test $os_win32 = "yes" ; then
- AC_MSG_CHECKING([for cximage])
- AC_TRY_CPP(
-[#include <ximage.h>
-int main()
-{
- return CXIMAGE_FORMAT_RAW;
-)}
-],[
- AC_MSG_RESULT([found])
- have_cximage="yes"
-]
-,[AC_MSG_RESULT([missing])
- CXIMAGE_CFLAGS='-DDISABLE_CXIMAGE'
- have_cximage="no"
- ]
-)
-fi
-AC_SUBST(CXIMAGE_CFLAGS)
-
-# check for windres for mingw32 builds
-if test $os_win32 = "yes" ; then
- AC_CHECK_PROGS(WINDRES,i686-pc-mingw32-windres mingw-windres mingw32-windres,false)
- AC_SUBST(WINDRES)
-fi
-
AC_SUBST(WARN_CFLAGS)
-AC_SUBST(CFLAGS_CFLAGS)
dnl =========================================================================
dnl -fvisibility stuff
@@ -534,7 +348,6 @@ spice-server.pc
server/Makefile
server/spice-version.h
server/tests/Makefile
-client/Makefile
docs/Makefile
docs/manual/Makefile
])
@@ -550,18 +363,8 @@ echo "
c++ compiler: ${CXX}
python: ${PYTHON}
- Build Spice client: ${enable_client}
-" ; if test "x$enable_client" = "xyes"; then echo "\
- Have XRANDR 1.2: ${have_xrandr12}
-
- Have Xinerama: ${have_xinerama}
-
- Red target: ${red_target}
-
OpenGL: ${enable_opengl}
- GUI: ${enable_gui}
-" ; fi ; echo "\
LZ4 support: ${enable_lz4}
Smartcard: ${enable_smartcard}
@@ -573,12 +376,6 @@ echo "
Manual: ${have_asciidoc}
"
-if test $os_win32 = "yes" ; then
-echo \
-" Copy & Paste Images: ${have_cximage}
-"
-fi
-
echo \
" Now type 'make' to build $PACKAGE
"