summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <ssp@redhat.com>2010-03-10 09:27:35 -0500
committerSøren Sandmann Pedersen <ssp@redhat.com>2010-03-11 06:37:41 -0500
commit46ad8fd0705e8705adc75038750492b3b9538a8e (patch)
tree0c126171b61c4606656ff3c02cf36e308ee7e88f /configure.ac
parentd94cb8e1ba324ba5e534b6cddb604a58d7e15138 (diff)
downloadspice-46ad8fd0705e8705adc75038750492b3b9538a8e.tar.gz
spice-46ad8fd0705e8705adc75038750492b3b9538a8e.tar.xz
spice-46ad8fd0705e8705adc75038750492b3b9538a8e.zip
Explicitly depend on various X libraries, and -pthread
In Fedora 13, the linker doesn't pull in DT_NEEDED libraries anymore, so we have to list the things that we depend on explicitly. This affects several X extension libraries, and also the pthread library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6f560682..fb8f67c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,7 +101,7 @@ AC_CHECK_LIB(rt, clock_gettime,
)
AC_SUBST(LIBRT)
-SPICE_NONPKGCONFIG_LIBS+=" $LIBM $LIBRT"
+SPICE_NONPKGCONFIG_LIBS+=" -pthread $LIBM $LIBRT"
SPICE_REQUIRES=""
@@ -189,6 +189,11 @@ if test "x$have_xrandr12" = "xyes" ; then
AC_DEFINE([HAVE_XRANDR12], [], [Define if we have XRANDR 12])
fi
+PKG_CHECK_MODULES(MISC_X, x11 xext xrender)
+AC_SUBST(MISC_X_CFLAGS)
+AC_SUBST(MISC_X_LIBS)
+SPICE_REQUIRES+=" x11 xext xrender"
+
# Add parameter for (partial) static linkage of spice client.
# this is used to achive single binary package for all (?) distros.
AC_ARG_ENABLE(static-linkage,