summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2010-03-17 22:09:41 +0100
committerAlexander Larsson <alexl@redhat.com>2010-03-17 22:09:41 +0100
commitf16e16393e128a335b5e2d22c21315881409e99f (patch)
treeb461e42864b56161d53ad95a74ab53e3b46cb954 /configure.ac
parentda21e89daa15d28aa7f485c532359fbfd6b940b5 (diff)
downloadspice-f16e16393e128a335b5e2d22c21315881409e99f.tar.gz
spice-f16e16393e128a335b5e2d22c21315881409e99f.tar.xz
spice-f16e16393e128a335b5e2d22c21315881409e99f.zip
Default opt flags to -O2
gcc -O3 has some code generation failures due to a combination of unaligned (packed) structs and vectorization that can cause a crash in canvas_localize_palette(). And its just safer to use -O2, which is the standard "trusted" optimization flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fb8f67c2..3f8190f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -203,12 +203,12 @@ AC_ARG_ENABLE(static-linkage,
AS_IF([test "$_cflags_is_set" = "yes"], [], [
- CFLAGS="-g -O3"
+ CFLAGS="-g -O2"
])
AS_IF([test "$_cxxflags_is_set" = "yes"], [], [
- CXXFLAGS="-g -O3"
+ CXXFLAGS="-g -O2"
])