summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorYonit Halperin <yhalperi@redhat.com>2010-04-06 18:07:49 +0300
committerAlexander Larsson <alexl@redhat.com>2010-04-06 17:45:04 +0200
commit4acf155fb2ced327495fe95e64bf62117f5d307a (patch)
treea0b37ece70ca6f9114dca4f58615baa5d3d1153c /configure.ac
parent88aa56045a57e760beb35e659731741dc15f3aac (diff)
downloadspice-4acf155fb2ced327495fe95e64bf62117f5d307a.tar.gz
spice-4acf155fb2ced327495fe95e64bf62117f5d307a.tar.xz
spice-4acf155fb2ced327495fe95e64bf62117f5d307a.zip
server configuration: make network redirection support optional
By default it is disabled. To enable: configure --enable-tunnel. When active, requires libslirp.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 16 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index aa9db5aa..c68d849e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,6 +88,13 @@ AM_CONDITIONAL(OS_UNIX, test "$os_win32" != "yes")
AM_CONDITIONAL(OS_LINUX, test "$os_linux" = "yes")
dnl =========================================================================
+dnl Chek optional features
+have_tunnel=no
+AC_ARG_ENABLE(tunnel,
+[ --enable-tunnel Enable network redirection],
+[ have_tunnel=yes])
+AM_CONDITIONAL(SUPPORT_TUNNEL, test "x$have_tunnel" = "xyes")
+dnl =========================================================================
dnl Check deps
PKG_CHECK_MODULES(PROTOCOL, spice-protocol)
@@ -118,10 +125,13 @@ AC_SUBST(CEGUI_CFLAGS)
AC_SUBST(CEGUI_LIBS)
SPICE_REQUIRES+=" CEGUI"
-PKG_CHECK_MODULES(SLIRP, slirp)
-AC_SUBST(SLIRP_CFLAGS)
-AC_SUBST(SLIRP_LIBS)
-SPICE_REQUIRES+=" slirp"
+if test "x$have_tunnel" = "xyes"; then
+ PKG_CHECK_MODULES(SLIRP, slirp)
+ AC_SUBST(SLIRP_CFLAGS)
+ AC_SUBST(SLIRP_LIBS)
+ SPICE_REQUIRES+=" slirp"
+ AC_DEFINE([HAVE_SLIRP], [], [Define if we have slirp])
+fi
PKG_CHECK_MODULES(PIXMAN, pixman-1 >= 0.17.7)
AC_SUBST(PIXMAN_CFLAGS)
@@ -345,6 +355,8 @@ echo "
Have XRANDR 1.2: ${have_xrandr12}
+ Support tunneling: ${have_tunnel}
+
Red target: ${red_target}
Now type 'make' to build $PACKAGE