summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2010-07-01 13:48:58 +0200
committerAlexander Larsson <alexl@redhat.com>2010-07-01 13:48:58 +0200
commit0e16cadc7077d448a5b91be205226620e2bc5191 (patch)
treeee3f97a1a9189956c8ca5aac25ed8975e5ee9787 /configure.ac
parentd69fd9408cecff72a9261ed5c1cc2de77aee37bb (diff)
downloadspice-0e16cadc7077d448a5b91be205226620e2bc5191.tar.gz
spice-0e16cadc7077d448a5b91be205226620e2bc5191.tar.xz
spice-0e16cadc7077d448a5b91be205226620e2bc5191.zip
Make CEGUI optional
This makes the CEGUI dependency optional and off by default. Restoring previous behaviour of exiting on disconnect if disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 15 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c78d1677..dc13caf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,6 +97,12 @@ AC_ARG_ENABLE(tunnel,
[ have_tunnel=yes])
AM_CONDITIONAL(SUPPORT_TUNNEL, test "x$have_tunnel" = "xyes")
+use_gui=no
+AC_ARG_ENABLE(gui,
+[ --enable-gui Enable start dialog with CEGUI],
+[ use_gui=yes])
+AM_CONDITIONAL(SUPPORT_GUI, test "x$use_gui" = "xyes")
+
have_opengl=no
AC_ARG_ENABLE(opengl,
[ --enable-opengl Enable opengl requirement / support (not recommended)],
@@ -121,10 +127,13 @@ SPICE_NONPKGCONFIG_LIBS+=" -pthread $LIBM $LIBRT"
SPICE_REQUIRES=""
-PKG_CHECK_MODULES(CEGUI, CEGUI >= 0.6.0 CEGUI < 0.7.0)
-AC_SUBST(CEGUI_CFLAGS)
-AC_SUBST(CEGUI_LIBS)
-SPICE_REQUIRES+=" CEGUI"
+if test "x$use_gui" = "xyes"; then
+ PKG_CHECK_MODULES(CEGUI, CEGUI >= 0.6.0 CEGUI < 0.7.0)
+ AC_SUBST(CEGUI_CFLAGS)
+ AC_SUBST(CEGUI_LIBS)
+ SPICE_REQUIRES+=" CEGUI"
+ CEGUI_CFLAGS+="-DUSE_GUI"
+fi
if test "x$have_tunnel" = "xyes"; then
PKG_CHECK_MODULES(SLIRP, slirp)
@@ -366,5 +375,7 @@ echo "
OpenGL: ${have_opengl}
+ GUI: ${use_gui}
+
Now type 'make' to build $PACKAGE
"