summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNikolay Orlyuk <virkony@gmail.com>2012-06-18 10:26:06 +0300
committerChristophe Fergeau <cfergeau@redhat.com>2012-06-19 11:56:28 +0200
commit95253b0fb5b5383ece1ea0f5b54e9cfc944bd765 (patch)
tree64b0983f83d5071cccf13166143b89ecacee57a9 /configure.ac
parent5cbffe794f156814bc1082b2a887ce6d62e87532 (diff)
downloadspice-95253b0fb5b5383ece1ea0f5b54e9cfc944bd765.tar.gz
spice-95253b0fb5b5383ece1ea0f5b54e9cfc944bd765.tar.xz
spice-95253b0fb5b5383ece1ea0f5b54e9cfc944bd765.zip
Added configure option --disable-xinerama
This parameter was added to be able to control dependency on libXinerama. Which is really useful for package managers. Fixes bug #51192
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index aee29755..8f9474ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -309,10 +309,23 @@ if test "x$have_xrandr12" = "xyes" ; then
AC_DEFINE([HAVE_XRANDR12], [], [Define if we have XRANDR 12])
fi
-PKG_CHECK_MODULES(XINERAMA,
+# Add parameter for libXinerama
+AC_ARG_ENABLE([xinerama],
+ [AS_HELP_STRING([--disable-xinerama],
+ [disable Xinerama library @<:@default=no@:>@])])
+
+if test "x$enable_xinerama" != "xno"; then
+ PKG_CHECK_MODULES(XINERAMA,
xinerama >= 1.0,
have_xinerama=yes,
have_xinerama=no)
+else
+ have_xinerama=no
+fi
+
+if test "x$enable_xinerama" = "xyes" && test "x$have_xinerama" = "xno"; then
+ AC_MSG_ERROR([Requested Xinerama library was not found])
+fi
AM_CONDITIONAL([HAVE_XINERAMA], [test "x$have_xinerama" = "xyes"])
if test "x$have_xinerama" = "xyes" ; then