summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2012-01-10 14:45:44 +0000
committerAlon Levy <alevy@redhat.com>2012-01-13 18:11:59 +0200
commit440ba5d8f0f5b2a3a9f4ae09095b186299b745b9 (patch)
tree0eac7e954505737a9ee750a2cb548bc67a5df9b3 /configure.ac
parent0de78e9f59ec1fd7f48e5c51b44a0fc98e682d55 (diff)
downloadspice-440ba5d8f0f5b2a3a9f4ae09095b186299b745b9.tar.gz
spice-440ba5d8f0f5b2a3a9f4ae09095b186299b745b9.tar.xz
spice-440ba5d8f0f5b2a3a9f4ae09095b186299b745b9.zip
Always quote first arg to AC_DEFINE
The first arg to AC_DEFINE should always be quoted
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index cf3eda69..a8dbc730 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,7 +99,7 @@ AC_ARG_ENABLE(tunnel,
AS_IF([test x"$enable_tunnel" != "xno"], [enable_tunnel="yes"])
AM_CONDITIONAL(SUPPORT_TUNNEL, test "x$enable_tunnel" != "xno")
if test "x$enable_tunnel" != "xno"; then
- AC_DEFINE(USE_TUNNEL, [1], [Define if supporting tunnel proxying])
+ AC_DEFINE([USE_TUNNEL], [1], [Define if supporting tunnel proxying])
fi
AC_ARG_ENABLE(gui,
@@ -120,7 +120,7 @@ AC_ARG_ENABLE(smartcard,
AS_IF([test x"$enable_smartcard" != "xno"], [enable_smartcard="yes"])
AM_CONDITIONAL(SUPPORT_SMARTCARD, test "x$enable_smartcard" != "xno")
if test "x$enable_smartcard" = "xyes"; then
- AC_DEFINE(USE_SMARTCARD, [1], [Define if supporting smartcard proxying])
+ AC_DEFINE([USE_SMARTCARD], [1], [Define if supporting smartcard proxying])
fi
AC_ARG_ENABLE(client,
@@ -139,7 +139,7 @@ AC_CHECK_LIBM
AC_SUBST(LIBM)
AC_CHECK_LIB(rt, clock_gettime,
- AC_DEFINE(HAVE_CLOCK_GETTIME, 1, [Defined if we have clock_gettime()])
+ AC_DEFINE([HAVE_CLOCK_GETTIME], 1, [Defined if we have clock_gettime()])
LIBRT=-lrt
)
AC_SUBST(LIBRT)
@@ -168,7 +168,7 @@ else
AC_MSG_RESULT($posix_yield_func)
posix_yield_func="$posix_yield_func()"
fi
-AC_DEFINE_UNQUOTED(POSIX_YIELD_FUNC,$posix_yield_func,[The POSIX RT yield function])
+AC_DEFINE_UNQUOTED([POSIX_YIELD_FUNC],$posix_yield_func,[The POSIX RT yield function])
SPICE_REQUIRES=""