summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-21 14:42:35 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-25 18:59:10 +0200
commit359fc1cb5dbbcf32132c3e8ee6f881a23deff684 (patch)
tree3ae7cc1c8b4d0449d50a13cb9640a6ef75f51f11 /common/Makefile.am
parent4df135c858d7dfb1aa0ae5d3cb17d786410d1544 (diff)
downloadspice-359fc1cb5dbbcf32132c3e8ee6f881a23deff684.tar.gz
spice-359fc1cb5dbbcf32132c3e8ee6f881a23deff684.tar.xz
spice-359fc1cb5dbbcf32132c3e8ee6f881a23deff684.zip
Use the spice-common submodule
This patch will replace the common/ directory with the spice-common project. It is for now a simple project subdirectory shared with spice-gtk, but the goal is to make it a proper library later on. With this change, the spice-server build is broken. The following commits fix the build, and have been seperated to ease the review. v2 - moves all the generated marshallers to spice-common library - don't attempt to fix windows VS build, which should somehow be splitted with spice-common (or built from tarball only to avoid generation tools/libs deps) v3 - uses libspice-common-client - fix a mutex.h inclusion reported by Alon
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am76
1 files changed, 0 insertions, 76 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
deleted file mode 100644
index 4189dc1f..00000000
--- a/common/Makefile.am
+++ /dev/null
@@ -1,76 +0,0 @@
-if OS_WIN32
-SUBDIRS = win
-endif
-
-NULL =
-
-noinst_LTLIBRARIES = libspice-common.la
-libspice_common_la_SOURCES = \
- bitops.h \
- canvas_utils.c \
- canvas_utils.h \
- draw.h \
- lines.c \
- lines.h \
- lz.c \
- lz.h \
- lz_common.h \
- lz_config.h \
- marshaller.c \
- marshaller.h \
- mem.c \
- mem.h \
- messages.h \
- mutex.h \
- pixman_utils.c \
- pixman_utils.h \
- quic.c \
- quic.h \
- quic_config.h \
- rect.h \
- region.c \
- region.h \
- ring.h \
- rop3.c \
- rop3.h \
- spice_common.h \
- ssl_verify.c \
- ssl_verify.h \
- backtrace.c \
- backtrace.h \
- $(NULL)
-
-if SUPPORT_GL
-libspice_common_la_SOURCES += \
- gl_utils.h \
- glc.h \
- glc.c \
- ogl_ctx.h \
- ogl_ctx.c \
- $(NULL)
-endif
-
-INCLUDES = \
- $(GL_CFLAGS) \
- $(PIXMAN_CFLAGS) \
- $(PROTOCOL_CFLAGS) \
- $(VISIBILITY_HIDDEN_CFLAGS) \
- $(WARN_CFLAGS) \
- -std=gnu99 \
- $(NULL)
-
-EXTRA_DIST = \
- canvas_base.c \
- canvas_base.h \
- gdi_canvas.c \
- gdi_canvas.h \
- gl_canvas.c \
- gl_canvas.h \
- sw_canvas.c \
- sw_canvas.h \
- lz_compress_tmpl.c \
- lz_decompress_tmpl.c \
- quic_family_tmpl.c \
- quic_rgb_tmpl.c \
- quic_tmpl.c \
- $(NULL)