summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2011-01-25 13:00:33 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2011-05-03 16:49:56 +0200
commitc16b1a924b161d8031193fc375be8e2773f8d0c1 (patch)
tree26a41f42b07e4fd7cde15e2ebc697f74995a9cef /common/Makefile.am
parent2b78b4968a514262d532626d7aee78ad4a481fd2 (diff)
downloadspice-c16b1a924b161d8031193fc375be8e2773f8d0c1.tar.gz
spice-c16b1a924b161d8031193fc375be8e2773f8d0c1.tar.xz
spice-c16b1a924b161d8031193fc375be8e2773f8d0c1.zip
common: add ssl_verify.c common code
Code adapter from RedPeer::ssl_verify_callback() and used by spice-gtk. Since v1: - fixed Makefile.am - added config.h include - autoconf alloca added in patch series - moved int escape inside for loop - added a failed case when missing assignment - replaced strlen () by -1 - skip spaces after comma - c++ guards I didn't use bool, because openSSL uses int, and it is more future proof for error reporting.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index dff9574b..e0f4d491 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -34,6 +34,8 @@ libspice_common_la_SOURCES = \
rop3.c \
rop3.h \
spice_common.h \
+ ssl_verify.c \
+ ssl_verify.h \
$(NULL)
if SUPPORT_GL