summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-04-20 17:50:22 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2011-05-03 14:44:10 +0200
commit2db7212175c51f4121790bfd1fd677c0b77833d5 (patch)
tree8511c736d8a6ca3c0adc43059ff47cdc53f9a980 /common/Makefile.am
parent253aa0c960ccb3fd2cd6f6b2550ef09b9cbd5d1a (diff)
downloadspice-2db7212175c51f4121790bfd1fd677c0b77833d5.tar.gz
spice-2db7212175c51f4121790bfd1fd677c0b77833d5.tar.xz
spice-2db7212175c51f4121790bfd1fd677c0b77833d5.zip
autotools: correctly build canvas-related code
spice client and spice server shares code from common/{gdi,gl,sw}_canvas.[ch]. However, while most of the code is shared, the server code wants a canvas compiled with SW_CANVAS_IMAGE_CACHE defined while the client code wants a canvas compiled with SW_CANVAS_CACHE. The initial autotools refactoring didn't take that into account, this is now fixed by this commit. After this commit, the canvas files from common/ are no longer compiled as part of the libspice-common.la convenience library. Instead, there are "proxy" canvas source files in client/ and server/ which #include the appropriate C files after defining the relevant #define for the binary that is being built. To prevent misuse of the canvas c files and headers in common/, SPICE_CANVAS_INTERNAL must be set when including the canvas headers from common/ or when building the c files from common/ otherwise the build will error out.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am20
1 files changed, 7 insertions, 13 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 0a2f9c16..501a6e15 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -6,7 +6,6 @@ NULL =
noinst_LTLIBRARIES = libspice-common.la
libspice_common_la_SOURCES = \
- canvas_base.h \
canvas_utils.c \
canvas_utils.h \
draw.h \
@@ -34,21 +33,10 @@ libspice_common_la_SOURCES = \
rop3.c \
rop3.h \
spice_common.h \
- sw_canvas.c \
- sw_canvas.h \
- $(NULL)
-
-if OS_WIN32
-libspice_common_la_SOURCES += \
- gdi_canvas.h \
- gdi_canvas.c \
$(NULL)
-endif
if SUPPORT_GL
libspice_common_la_SOURCES += \
- gl_canvas.h \
- gl_canvas.c \
gl_utils.h \
glc.h \
glc.c \
@@ -58,7 +46,6 @@ libspice_common_la_SOURCES += \
endif
INCLUDES = \
- -DSW_CANVAS_IMAGE_CACHE \
$(GL_CFLAGS) \
$(PIXMAN_CFLAGS) \
$(PROTOCOL_CFLAGS) \
@@ -69,6 +56,13 @@ INCLUDES = \
EXTRA_DIST = \
canvas_base.c \
+ canvas_base.h \
+ gdi_canvas.c \
+ gdi_canvas.h \
+ gl_canvas.c \
+ gl_canvas.h \
+ sw_canvas.c \
+ sw_canvas.h \
lz_compress_tmpl.c \
lz_decompress_tmpl.c \
quic_family_tmpl.c \