summaryrefslogtreecommitdiffstats
path: root/client/x11/Makefile.am
diff options
context:
space:
mode:
authorYaniv Kamay <ykamay@redhat.com>2009-12-28 00:31:35 +0200
committerYaniv Kamay <ykamay@redhat.com>2009-12-28 12:37:01 +0200
commitce480b07335d8f7d380ac302a1a6422c4fa3742b (patch)
treec60f73f0887ee0e66a11cc6d3fd723427eb19c99 /client/x11/Makefile.am
parent2dbaf8c00c28770e48cbfc6ab3300000118d22ec (diff)
downloadspice-ce480b07335d8f7d380ac302a1a6422c4fa3742b.tar.gz
spice-ce480b07335d8f7d380ac302a1a6422c4fa3742b.tar.xz
spice-ce480b07335d8f7d380ac302a1a6422c4fa3742b.zip
client: add soft renderer and cegui
Diffstat (limited to 'client/x11/Makefile.am')
-rw-r--r--client/x11/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/client/x11/Makefile.am b/client/x11/Makefile.am
index 99f0c26a..072548db 100644
--- a/client/x11/Makefile.am
+++ b/client/x11/Makefile.am
@@ -22,6 +22,7 @@ INCLUDES = \
$(CELT051_CFLAGS) \
$(SSL_CFLAGS) \
$(XRANDR_CFLAGS) \
+ $(CEGUI_CFLAGS) \
$(WARN_CFLAGS) \
$(NULL)
@@ -101,7 +102,11 @@ RED_COMMON_SRCS = \
$(top_srcdir)/client/tunnel_channel.h \
$(top_srcdir)/client/utils.cpp \
$(top_srcdir)/client/utils.h \
- $(top_srcdir)/client/icon.h \
+ $(top_srcdir)/client/icon.h \
+ $(top_srcdir)/client/gui/softrenderer.h \
+ $(top_srcdir)/client/gui/softrenderer.cpp \
+ $(top_srcdir)/client/gui/softtexture.h \
+ $(top_srcdir)/client/gui/softtexture.cpp \
$(NULL)
bin_PROGRAMS = spicec
@@ -141,7 +146,7 @@ spicec_LDFLAGS = \
$(LOG4CPP_LIBS) \
$(CELT051_LIBS) \
$(SSL_LIBS) \
- $(SPICEC_STATIC_LINKAGE_BDYNAMIC)
+ $(CEGUI_LIBS)
spicec_LDADD = \
$(QCAIRO_LIBS) \
@@ -149,5 +154,6 @@ spicec_LDADD = \
$(ALSA_LIBS) \
$(GL_LIBS) \
$(XRANDR_LIBS) \
+ $(CEGUI_LIBS) \
-lrt