summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2010-06-21 14:17:29 +0200
committerAlexander Larsson <alexl@redhat.com>2010-06-21 14:50:18 +0200
commitcfc1e95bda0e150b3de225c3572bb1004dad070e (patch)
treee672e2607613ac012f0cfe3414a33b129bae52b2 /client/Makefile.am
parentae4436215cb113a02eac73c6afd368166090967c (diff)
downloadspice-cfc1e95bda0e150b3de225c3572bb1004dad070e.tar.gz
spice-cfc1e95bda0e150b3de225c3572bb1004dad070e.tar.xz
spice-cfc1e95bda0e150b3de225c3572bb1004dad070e.zip
Make opengl optional, disabled by default
The OpenGL renderer isn't really useful right now, its not quite up to date, its not really faster than software and it only supports a limited subset of drivers. So, lets disable it for now. Long term opengl rendering of the 2d part of spice is important if we want to combine 2d and 3d rendering (say if spice adds opengl support in the protocol). But until then this is isn't useful for normal use.
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am18
1 files changed, 12 insertions, 6 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 86d7c3e3..f700ed65 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -15,6 +15,17 @@ generated_marshallers.cpp: $(top_srcdir)/spice.proto
generated_marshallers.h: $(top_srcdir)/spice.proto
$(PYTHON) $(top_srcdir)/spice_codegen.py --generate-marshallers $(STRUCTS) --client -H $(top_srcdir)/spice.proto generated_marshallers.h
+if SUPPORT_GL
+GL_SRCS = \
+ gl_canvas.cpp \
+ glc.cpp \
+ red_gl_canvas.cpp \
+ red_gl_canvas.h \
+ red_pixmap_gl.h
+else
+GL_SRCS =
+endif
+
RED_COMMON_SRCS = \
application.cpp \
application.h \
@@ -46,10 +57,6 @@ RED_COMMON_SRCS = \
debug.h \
display_channel.cpp \
display_channel.h \
- red_gl_canvas.cpp \
- red_gl_canvas.h \
- gl_canvas.cpp \
- glc.cpp \
glz_decoded_image.h \
glz_decoder_config.h \
glz_decoder.cpp \
@@ -86,7 +93,6 @@ RED_COMMON_SRCS = \
red_peer.cpp \
red_peer.h \
red_pixmap_sw.h \
- red_pixmap_gl.h \
red_pixmap.h \
red_types.h \
red_window.h \
@@ -109,6 +115,6 @@ RED_COMMON_SRCS = \
MAINTAINERCLEANFILES = $(spice_built_sources)
-EXTRA_DIST = $(RED_COMMON_SRCS) $(spice_built_sources)
+EXTRA_DIST = $(RED_COMMON_SRCS) $(spice_built_sources) $(GL_SRCS)
BUILT_SOURCES = $(spice_built_sources)