summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorYaniv Kamay <ykamay@redhat.com>2009-09-19 21:25:46 +0300
committerYaniv Kamay <ykamay@redhat.com>2009-10-14 15:06:41 +0200
commitc1b79eb035fa158fb2ac3bc8e559809611070016 (patch)
tree3348dd749a700dedf87c9b16fe8be77c62928df8 /client/Makefile.am
downloadspice-c1b79eb035fa158fb2ac3bc8e559809611070016.tar.gz
spice-c1b79eb035fa158fb2ac3bc8e559809611070016.tar.xz
spice-c1b79eb035fa158fb2ac3bc8e559809611070016.zip
fresh start
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am82
1 files changed, 82 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
new file mode 100644
index 00000000..bb78ba49
--- /dev/null
+++ b/client/Makefile.am
@@ -0,0 +1,82 @@
+NULL =
+
+SUBDIRS = $(red_target)
+DIST_SUBDIRS = x11 #windows
+
+RED_COMMON_SRCS = \
+ application.cpp \
+ application.h \
+ audio_channels.h \
+ audio_devices.h \
+ cache.hpp \
+ cairo_canvas.cpp \
+ canvas.cpp \
+ canvas.h \
+ canvas_utils.cpp \
+ red_cairo_canvas.cpp \
+ red_cairo_canvas.h \
+ cmd_line_parser.cpp \
+ cmd_line_parser.h \
+ common.h \
+ cursor_channel.cpp \
+ cursor_channel.h \
+ cursor.cpp \
+ cursor.h \
+ debug.h \
+ display_channel.cpp \
+ display_channel.h \
+ events_loop.h \
+ red_gl_canvas.cpp \
+ red_gl_canvas.h \
+ gl_canvas.cpp \
+ glc.cpp \
+ glz_decoded_image.h \
+ glz_decoder_config.h \
+ glz_decoder.cpp \
+ glz_decoder.h \
+ glz_decoder_window.cpp \
+ glz_decoder_window.h \
+ glz_decode_tmpl.c \
+ inputs_channel.cpp \
+ inputs_channel.h \
+ inputs_handler.h \
+ lz.cpp \
+ monitor.cpp \
+ monitor.h \
+ menu.cpp \
+ menu.h \
+ pixels_source.h \
+ platform.h \
+ playback_channel.cpp \
+ quic.cpp \
+ read_write_mutex.h \
+ record_channel.cpp \
+ red_channel.cpp \
+ red_channel.h \
+ red_client.cpp \
+ red_client.h \
+ red_drawable.h \
+ red_key.h \
+ red_peer.cpp \
+ red_peer.h \
+ red_pixmap_cairo.h \
+ red_pixmap_gl.h \
+ red_pixmap.h \
+ red_types.h \
+ red_window.h \
+ region.cpp \
+ rop3.cpp \
+ screen.cpp \
+ screen.h \
+ screen_layer.cpp \
+ screen_layer.h \
+ shared_cache.hpp \
+ hot_keys.cpp \
+ hot_keys.h \
+ threads.cpp \
+ threads.h \
+ utils.cpp \
+ utils.h \
+ $(NULL)
+
+EXTRA_DIST = $(RED_COMMON_SRCS)