summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2010-05-26 13:59:51 +0200
committerAlexander Larsson <alexl@redhat.com>2010-06-18 16:32:11 +0200
commit17bbef4df334bd8d98d3960143f229d753b4b0a3 (patch)
treeadb94120d509b286132f962b5207a44bfd054030 /client/Makefile.am
parentb228d18d5c8a2feb8319de50d5e6cc8925e11545 (diff)
downloadspice-17bbef4df334bd8d98d3960143f229d753b4b0a3.tar.gz
spice-17bbef4df334bd8d98d3960143f229d753b4b0a3.tar.xz
spice-17bbef4df334bd8d98d3960143f229d753b4b0a3.zip
Generate demarshallers in client
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 55bc0f82..ab80bfbd 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -1,8 +1,13 @@
NULL =
-SUBDIRS = $(red_target)
+SUBDIRS = . $(red_target)
DIST_SUBDIRS = x11 #windows
+spice_built_sources = generated_demarshallers.cpp
+
+generated_demarshallers.cpp: $(top_srcdir)/spice.proto
+ $(PYTHON) $(top_srcdir)/spice_codegen.py --generate-demarshallers --client --include common.h $(top_srcdir)/spice.proto generated_demarshallers.cpp
+
RED_COMMON_SRCS = \
application.cpp \
application.h \
@@ -90,4 +95,8 @@ RED_COMMON_SRCS = \
utils.h \
$(NULL)
-EXTRA_DIST = $(RED_COMMON_SRCS)
+MAINTAINERCLEANFILES = $(spice_built_sources)
+
+EXTRA_DIST = $(RED_COMMON_SRCS) $(spice_built_sources)
+
+BUILT_SOURCES = $(spice_built_sources)