summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2012-01-13 12:35:38 +0200
committerAlon Levy <alevy@redhat.com>2012-01-13 17:42:21 +0200
commit01102ff62b96ac67089f75bc5dc404f3d49f1d88 (patch)
tree3a2004f5a88a37c5e8bd517c935de59113b2970d /client/Makefile.am
parent9d2768d7de0d17fea15b5bfaff5b73eee5f57891 (diff)
downloadspice-01102ff62b96ac67089f75bc5dc404f3d49f1d88.tar.gz
spice-01102ff62b96ac67089f75bc5dc404f3d49f1d88.tar.xz
spice-01102ff62b96ac67089f75bc5dc404f3d49f1d88.zip
client/Makefile.am: mingw32 fixes
* build resource file with windres * include client/windows and not client/x11 * use CXIMAGE_CFLAGS (it's already set to -DDISABLE_CXIMAGE correctly)
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index f7c9c56a..c4b5fe1f 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -136,6 +136,11 @@ spicec_SOURCES += \
windows/stdint.h \
windows/win_platform.h \
$(NULL)
+
+spicec_resource_LDADD = windows/redc.o
+
+windows/redc.o: windows/redc.rc
+ $(WINDRES) $< -o $@
else
spicec_SOURCES += \
x11/atomic_count.h \
@@ -167,6 +172,12 @@ spicec_SOURCES += \
$(NULL)
endif
+if OS_WIN32
+PLATFORM_INCLUDES=-I$(top_srcdir)/client/windows
+else
+PLATFORM_INCLUDES=-I$(top_srcdir)/client/x11
+endif
+
if SUPPORT_TUNNEL
spicec_SOURCES += \
tunnel_channel.cpp \
@@ -210,7 +221,7 @@ endif
INCLUDES = \
-D__STDC_LIMIT_MACROS \
- -I$(top_srcdir)/client/x11 \
+ $(PLATFORM_INCLUDES) \
-I$(top_srcdir)/common \
$(ALSA_CFLAGS) \
$(CEGUI_CFLAGS) \
@@ -227,6 +238,7 @@ INCLUDES = \
$(XFIXES_CFLAGS) \
$(WARN_CFLAGS) \
$(XINERAMA_CFLAGS) \
+ $(CXIMAGE_CFLAGS) \
$(NULL)
spicec_LDFLAGS = $(SPICEC_STATIC_LINKAGE_BSTATIC)
@@ -248,6 +260,7 @@ spicec_LDADD = \
$(XRANDR_LIBS) \
$(Z_LIBS) \
$(XINERAMA_LIBS) \
+ $(spicec_resource_LDADD) \
$(NULL)
EXTRA_DIST = \