summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2010-07-08 19:22:39 +0200
committerAlexander Larsson <alexl@redhat.com>2010-07-08 20:20:35 +0200
commitceff16cad6a9191d634b83b2914096e7564924e7 (patch)
treefa6099ae210a4da9e40ae43dbabc86ab73aa9aab /client/Makefile.am
parent0c505931dc5cb8edee36d6613cb70946df1ed430 (diff)
downloadspice-ceff16cad6a9191d634b83b2914096e7564924e7.tar.gz
spice-ceff16cad6a9191d634b83b2914096e7564924e7.tar.xz
spice-ceff16cad6a9191d634b83b2914096e7564924e7.zip
Make distcheck work
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index d5602b52..185518a9 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -1,7 +1,7 @@
NULL =
-SUBDIRS = . $(red_target)
-DIST_SUBDIRS = x11 #windows
+SUBDIRS = . $(red_target) gui
+DIST_SUBDIRS = x11 windows gui
spice_built_sources = generated_demarshallers.cpp generated_marshallers.cpp generated_demarshallers1.cpp generated_marshallers1.cpp
@@ -81,10 +81,12 @@ RED_COMMON_SRCS = \
menu.h \
mjpeg_decoder.h \
mjpeg_decoder.cpp \
+ event_sources.h \
pixels_source.h \
platform.h \
playback_channel.cpp \
process_loop.cpp \
+ process_loop.h \
quic.cpp \
read_write_mutex.h \
record_channel.cpp \
@@ -119,8 +121,15 @@ RED_COMMON_SRCS = \
zlib_decoder.h \
$(NULL)
+GDI_FILES = \
+ gdi_canvas.cpp \
+ red_gdi_canvas.cpp \
+ red_gdi_canvas.h \
+ red_pixmap_gdi.h \
+ $(NULL)
+
MAINTAINERCLEANFILES = $(spice_built_sources)
-EXTRA_DIST = $(RED_COMMON_SRCS) $(spice_built_sources) $(GL_SRCS)
+EXTRA_DIST = $(RED_COMMON_SRCS) $(spice_built_sources) $(GL_SRCS) $(GDI_FILES)
BUILT_SOURCES = $(spice_built_sources)