summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-21 14:42:35 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-25 18:59:10 +0200
commit359fc1cb5dbbcf32132c3e8ee6f881a23deff684 (patch)
tree3ae7cc1c8b4d0449d50a13cb9640a6ef75f51f11 /Makefile.am
parent4df135c858d7dfb1aa0ae5d3cb17d786410d1544 (diff)
downloadspice-359fc1cb5dbbcf32132c3e8ee6f881a23deff684.tar.gz
spice-359fc1cb5dbbcf32132c3e8ee6f881a23deff684.tar.xz
spice-359fc1cb5dbbcf32132c3e8ee6f881a23deff684.zip
Use the spice-common submodule
This patch will replace the common/ directory with the spice-common project. It is for now a simple project subdirectory shared with spice-gtk, but the goal is to make it a proper library later on. With this change, the spice-server build is broken. The following commits fix the build, and have been seperated to ease the review. v2 - moves all the generated marshallers to spice-common library - don't attempt to fix windows VS build, which should somehow be splitted with spice-common (or built from tarball only to avoid generation tools/libs deps) v3 - uses libspice-common-client - fix a mutex.h inclusion reported by Alon
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c277506..69714259 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
+NULL =
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = common server python_modules
-DIST_SUBDIRS = spice-protocol $(SUBDIRS)
+SUBDIRS = spice-common server
if SUPPORT_CLIENT
SUBDIRS += client
@@ -10,9 +10,11 @@ endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = spice-server.pc
-DISTCLEANFILES = \
- spice-server.pc
-
-EXTRA_DIST = spice.proto spice1.proto spice_codegen.py
-
-DISTCHECK_CONFIGURE_FLAGS=--enable-opengl --enable-gui --enable-tunnel --enable-smartcard --with-sasl --enable-automated-tests
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-automated-tests \
+ --enable-gui \
+ --enable-opengl \
+ --enable-smartcard \
+ --enable-tunnel \
+ --with-sasl \
+ $(NULL)