summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2012-10-16 14:45:07 +0200
committerAlon Levy <alevy@redhat.com>2012-10-19 14:15:06 +0200
commit761ce024066a5825bf372dbdb5e728b210d9b28c (patch)
treef0ef07b76f9f6a46fa88dac9f772d15ed90ebf16 /Makefile.am
parentcb27e9dad6f25630b95dc7d9acffdb556aeff174 (diff)
downloadspice-761ce024066a5825bf372dbdb5e728b210d9b28c.tar.gz
spice-761ce024066a5825bf372dbdb5e728b210d9b28c.tar.xz
spice-761ce024066a5825bf372dbdb5e728b210d9b28c.zip
add git-version-gen and gitlog-to-changelog
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 50a1a388..e2cab09c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,3 +16,25 @@ DISTCHECK_CONFIGURE_FLAGS = \
--enable-smartcard \
--with-sasl \
$(NULL)
+
+EXTRA_DIST = \
+ build-aux/git-version-gen \
+ $(NULL)
+
+# Generate the ChangeLog file (with all entries since the switch to git)
+# and insert it into the directory we're about to use to create a tarball.
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ if test -d .git || test -d ../.git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
+# see git-version-gen
+dist-hook: gen-ChangeLog
+ echo $(VERSION) > $(distdir)/.tarball-version
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@