summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index e8d118d..6d96f76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,25 +14,8 @@ AM_MAINTAINER_MODE
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
-dnl Enable generation of enums.h, mainly useful when building from git,
-dnl should not be needed for tarball users
-AC_ARG_ENABLE([code-generator],
- AS_HELP_STRING([--enable-code-generator=@<:@yes/no/auto@:>@],
- [Enable checks needed to use the Python code generator @<:@default=auto@:>@]),
- [],
- [enable_code_generator="auto"])
-if test "x$enable_code_generator" != "xno"; then
- AS_IF([test "x$enable_code_generator" = "xyes"], modules_required=[1], modules_required=[])
- AX_PYTHON_MODULE([six], $modules_required)
- AX_PYTHON_MODULE([pyparsing], $modules_required)
- AS_IF([test "x${HAVE_PYMOD_SIX}" = "xno"], enable_code_generator="no")
- AS_IF([test "x${HAVE_PYMOD_PYPARSING}" = "xno"], enable_code_generator="no")
-fi
-AM_CONDITIONAL([ENABLE_CODEGEN], [test "x$enable_code_generator" != "xno"])
-
AC_OUTPUT([
Makefile
spice-protocol.pc
spice/Makefile
-python_modules/Makefile
])