summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <mlureau@redhat.com>2015-11-11 22:41:54 +0100
committerMarc-André Lureau <marcandre.lureau@gmail.com>2016-02-16 14:22:24 +0100
commitf81ffa25ae406afe566ceeaa9e5d9fa191ea34b3 (patch)
treef54036938b7b275aa0984c462326214e5d7e0a50 /src/Makefile.am
parent1e4c78e3045536bf4c8fed2a11f955e0985e9335 (diff)
downloadspice-gtk-f81ffa25ae406afe566ceeaa9e5d9fa191ea34b3.tar.gz
spice-gtk-f81ffa25ae406afe566ceeaa9e5d9fa191ea34b3.tar.xz
spice-gtk-f81ffa25ae406afe566ceeaa9e5d9fa191ea34b3.zip
gtk: add spice-widget GL scanout support
Hook to spice-glib events to show the GL scanout. The opengl context is created with egl, and is currently x11-only (supporting wayland with bare-egl doesn't seem trivial). Using GtkGLArea is left for a future series, since SpiceDisplay widget is a GtkDrawingArea and can't be replaced without breaking ABI. Furthermore, GtkGLArea won't work on non-egl contexts, so this approach is necessary on gtk+ < 3.16 or X11 (because gdk/x11 uses glx). Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Acked-by: Victor Toso <victortoso@redhat.com> Acked-by: Pavel Grunt <pgrunt@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 37b89fe..68884e6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -122,6 +122,7 @@ SPICE_GTK_LIBADD_COMMON = \
libspice-client-glib-2.0.la \
$(GTK_LIBS) \
$(CAIRO_LIBS) \
+ $(EPOXY_LIBS) \
$(LIBM) \
$(NULL)
@@ -160,17 +161,25 @@ SPICE_GTK_SOURCES_COMMON += \
endif
if WITH_GTK
+if WITH_EPOXY
+SPICE_GTK_SOURCES_COMMON += \
+ spice-widget-egl.c \
+ $(NULL)
+endif
+
if HAVE_GTK_2
libspice_client_gtk_2_0_la_DEPEDENCIES = $(GTK_SYMBOLS_FILE)
libspice_client_gtk_2_0_la_LDFLAGS = $(SPICE_GTK_LDFLAGS_COMMON)
libspice_client_gtk_2_0_la_LIBADD = $(SPICE_GTK_LIBADD_COMMON)
libspice_client_gtk_2_0_la_SOURCES = $(SPICE_GTK_SOURCES_COMMON)
+libspice_client_gtk_2_0_la_CFLAGS = $(EPOXY_CFLAGS)
nodist_libspice_client_gtk_2_0_la_SOURCES = $(nodist_SPICE_GTK_SOURCES_COMMON)
else
libspice_client_gtk_3_0_la_DEPEDENCIES = $(GTK_SYMBOLS_FILE)
libspice_client_gtk_3_0_la_LDFLAGS = $(SPICE_GTK_LDFLAGS_COMMON)
libspice_client_gtk_3_0_la_LIBADD = $(SPICE_GTK_LIBADD_COMMON)
libspice_client_gtk_3_0_la_SOURCES = $(SPICE_GTK_SOURCES_COMMON)
+libspice_client_gtk_3_0_la_CFLAGS = $(EPOXY_CFLAGS)
nodist_libspice_client_gtk_3_0_la_SOURCES = $(nodist_SPICE_GTK_SOURCES_COMMON)
endif