summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2012-06-13 15:43:45 +0200
committerHans de Goede <hdegoede@redhat.com>2012-07-06 09:27:42 +0200
commit633586ba643f474235d1fc0a4656f8e00f2ffcac (patch)
tree5cff1e5d2dd7f01222e0430befbc91e5ba3c649b /configure.ac
parent7e8380414fc837b7b0fcc37df654350fe5be9734 (diff)
downloadspice-gtk-633586ba643f474235d1fc0a4656f8e00f2ffcac.tar.gz
spice-gtk-633586ba643f474235d1fc0a4656f8e00f2ffcac.tar.xz
spice-gtk-633586ba643f474235d1fc0a4656f8e00f2ffcac.zip
Add a desktop-integration helper class
We need to integrate closely with the desktop environment of the user in several cases. Some examples are disabling auto-mounting when auto-usbredir is active (rhbz#812972), and disabling the screensaver when fullscreen (fdo#34793). Unfortuntely these kinds of things require desktop environment specific handling. Therefor this patch introduces a desktop-integration helper class, which is to server as a container for all sort of desktop environment specific functions. For now it just supports disabling automounting under Gnome, but this will be extended in the future. Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 09129b7..3841c56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -566,6 +566,26 @@ fi
AM_CONDITIONAL(WITH_PYTHON, [test "$WITH_PYTHON" = "yes"])
+
+AC_ARG_ENABLE([dbus],
+ AS_HELP_STRING([--enable-dbus=@<:@auto/yes/no@:>@],
+ [Enable dbus support for desktop integration (disabling automount) @<:@default=auto@:>@]),
+ [],
+ [enable_dbus="auto"])
+
+if test "x$enable_dbus" != "xno"; then
+ PKG_CHECK_MODULES([DBUS_GLIB], [dbus-glib-1],
+ [have_dbus=yes],
+ [have_dbus=no])
+ if test "x$enable_dbus" = "xyes" && test "x$have_dbus" = "xno"; then
+ AC_MSG_ERROR([D-Bus support explicitly requested, but some required packages are not available])
+ fi
+
+ if test "x$have_dbus" = "xyes"; then
+ AC_DEFINE(USE_DBUS, [1], [Define if supporting dbus])
+ fi
+fi
+
dnl ===========================================================================
dnl check compiler flags