summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3efd57e..fcb05b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,11 @@ AC_PROG_YACC
AM_PATH_GLIB_2_0([2.12.0])
PKG_CHECK_MODULES([GSF], [libgsf-1])
+PKG_CHECK_MODULES([UUID], [uuid], [uuid=yes], [uuid=no])
+AS_IF([test "$uuid" = yes],
+ [AC_DEFINE([HAVE_LIBUUID], 1,
+ [Define to 1 if libuuid is present on the system])],
+ [AC_MSG_WARN([libuuid not found, msibuild will generate packages without a GUID])])
LT_INIT([win32-dll disable-fast-install])