summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f8dd3cc..5071300 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -113,6 +113,17 @@ installcheck-local: $(srcdir)/tests/testsuite atconfig atlocal
clean-local:
-$(SHELL) $(srcdir)/tests/testsuite --clean
+dist-hook:
+ @for file in `cd $(srcdir)/tests && \
+ $(AUTOM4TE) --language=autotest --trace='AT_MSIDATA:tests/data/$$1' \
+ testsuite.at`; do \
+ dir=`echo "/$$file" | sed -e 's,/[^/]*$$,,'`; \
+ $(MKDIR_P) "$(distdir)$$dir" || exit 1; \
+ echo cp -fpR $(srcdir)/$$file "$(distdir)$$dir"; \
+ cp -fpR $(srcdir)/$$file "$(distdir)$$dir" || exit 1; \
+ done
+
+
$(srcdir)/tests/testsuite: tests/testsuite.at tests/wixl.at tests/package.m4
cd $(srcdir)/tests && \
$(AUTOM4TE) --language=autotest -o testsuite.tmp testsuite.at && \