summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2012-10-22 10:18:57 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2012-10-22 10:51:11 +0200
commiteb59fe88595685f56db50540ec5626c7c24c454a (patch)
treecf12783c8fdbab451a1f3afdea78ee98b00c9de4 /configure.ac
downloadmsitools-eb59fe88595685f56db50540ec5626c7c24c454a.tar.gz
msitools-eb59fe88595685f56db50540ec5626c7c24c454a.tar.xz
msitools-eb59fe88595685f56db50540ec5626c7c24c454a.zip
initial commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f196c11
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,21 @@
+AC_INIT([msitools], [0.0])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([libmsi/sql.y])
+AM_INIT_AUTOMAKE([foreign])
+
+AC_PROG_CC
+AC_PROG_YACC
+
+AC_CHECK_TOOLS([WIDL], [widl],
+ [AC_MSG_ERROR([could not find widl])])
+
+AC_ARG_VAR([RCFLAGS], [Flags for the Windows resource compiler])
+AC_ARG_VAR([IDLFLAGS], [Flags for the Windows IDL compiler])
+
+LT_INIT([win32-dll disable-fast-install])
+LT_LANG([Windows Resource])
+
+AC_CONFIG_FILES([Makefile libmsi/Makefile])
+AC_OUTPUT