summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2013-01-18 09:01:43 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2013-01-18 09:11:40 +0100
commitd16ee17c08a383b77070f3ba40d91882c0cb56e8 (patch)
treebc4c7622fa5afb2d70871cd7ecff30ecd0b8c4b3 /Makefile.am
parentc1fd3ca2b91b675c038816076f671e778907d9ce (diff)
downloadmsitools-d16ee17c08a383b77070f3ba40d91882c0cb56e8.tar.gz
msitools-d16ee17c08a383b77070f3ba40d91882c0cb56e8.tar.xz
msitools-d16ee17c08a383b77070f3ba40d91882c0cb56e8.zip
wixl: remove gio-unix dependency
It is not available under Windows, but it can be easily implemented using Posix.read.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index beae662..0ef1e3b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -104,7 +104,8 @@ wixl_LDADD = \
wixl_DEPENDENCIES = libmsi/libmsi.la
-if !WIN32
+# Wixl-heat
+
bin_PROGRAMS += wixl-heat
wixl_heat_CFLAGS = -w
@@ -112,8 +113,9 @@ wixl_heat_CFLAGS = -w
wixl_heat_VALAFLAGS = \
--vapidir=. \
--pkg config \
+ --pkg gio-2.0 \
+ --pkg posix \
--enable-experimental \
- --pkg gio-unix-2.0 \
$(NULL)
wixl_heat_SOURCES = \
@@ -123,7 +125,6 @@ wixl_heat_SOURCES = \
wixl_heat_CPPFLAGS = $(wixl_CPPFLAGS)
wixl_heat_LDADD = $(wixl_LDADD)
-endif
# Autotest support