summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2013-01-25 14:28:42 +0100
committerMarc-André Lureau <marcandre.lureau@gmail.com>2013-01-25 14:28:42 +0100
commitb7346c11677f1592cf530ccb1190655a31998dd0 (patch)
tree973e751c017cd6c05022bf278bdf249b5f7645ef /Makefile.am
parenta747780b602e4800193e7a3c91b79e0cbd8da5cb (diff)
downloadmsitools-b7346c11677f1592cf530ccb1190655a31998dd0.tar.gz
msitools-b7346c11677f1592cf530ccb1190655a31998dd0.tar.xz
msitools-b7346c11677f1592cf530ccb1190655a31998dd0.zip
build-sys: install bash completion
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 687e798..756332c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,5 @@
NULL =
+EXTRA_DIST =
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = include data libmsi tests po .
@@ -127,6 +128,12 @@ wixl_heat_SOURCES = \
wixl_heat_CPPFLAGS = $(wixl_CPPFLAGS)
wixl_heat_LDADD = $(wixl_LDADD)
+# bash completion
+
+completiondir = $(datadir)/bash-completion/completions
+completion_DATA = completion/msitools
+EXTRA_DIST += $(completion_DATA)
+
# Autotest support
dist_noinst_DATA = tests/testsuite.at tests/wixl.at tests/package.m4 tests/testsuite
@@ -158,4 +165,4 @@ $(srcdir)/tests/testsuite: tests/testsuite.at tests/wixl.at tests/package.m4
$(AUTOM4TE) --language=autotest -o testsuite.tmp testsuite.at && \
mv testsuite.tmp testsuite
-EXTRA_DIST = msitools.doap build-aux/move-if-change autogen.sh
+EXTRA_DIST += msitools.doap build-aux/move-if-change autogen.sh