summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2013-01-10 16:05:32 +0100
committerMarc-André Lureau <marcandre.lureau@gmail.com>2013-01-11 13:10:34 +0100
commit734bddba1cfa2a712a99a1bff784a617aec73c45 (patch)
treedf02b9362cb0ac1c5d16ded1ae91953be26b0a9e /Makefile.am
parent1e664f3c0f043297b5d90cd596cfa04ed901b6be (diff)
downloadmsitools-734bddba1cfa2a712a99a1bff784a617aec73c45.tar.gz
msitools-734bddba1cfa2a712a99a1bff784a617aec73c45.tar.xz
msitools-734bddba1cfa2a712a99a1bff784a617aec73c45.zip
tools: add wixl-heat
A tool to generate WiX fragments
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 76d4aa0..c7c1cef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -77,6 +77,27 @@ wixl_LDADD = \
wixl_DEPENDENCIES = libmsi/libmsi.la
+if !WIN32
+bin_PROGRAMS += wixl-heat
+
+wixl_heat_CFLAGS = -w
+
+wixl_heat_VALAFLAGS = \
+ --vapidir=. \
+ --pkg config \
+ --enable-experimental \
+ --pkg gio-unix-2.0 \
+ $(NULL)
+
+wixl_heat_SOURCES = \
+ tools/wixl/wixl-heat.vala \
+ tools/wixl/util.vala \
+ $(NULL)
+
+wixl_heat_CPPFLAGS = $(wixl_CPPFLAGS)
+wixl_heat_LDADD = $(wixl_LDADD)
+endif
+
# Autotest support
dist_noinst_DATA = tests/testsuite.at tests/package.m4 tests/testsuite