summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2013-01-17 03:32:23 +0100
committerMarc-André Lureau <marcandre.lureau@gmail.com>2013-01-17 03:32:23 +0100
commitceb4e1d3de8304c233b5294e2161fca1b7a3785e (patch)
treee155cf73ba9932cc23ccffaaa606f2f44c6971dc /Makefile.am
parente5ceb0c21bf680088a17321f18a00eea439cff54 (diff)
downloadmsitools-ceb4e1d3de8304c233b5294e2161fca1b7a3785e.tar.gz
msitools-ceb4e1d3de8304c233b5294e2161fca1b7a3785e.tar.xz
msitools-ceb4e1d3de8304c233b5294e2161fca1b7a3785e.zip
Start a msiextract tool
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1c44715..7f790ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,6 +29,29 @@ msiinfo_SOURCES = tools/msiinfo.c
msiinfo_LDADD = -lmsi $(GLIB_LIBS) $(GSF_LIBS)
msiinfo_DEPENDENCIES = libmsi/libmsi.la
+# msiextract, something on the TODO list...
+
+noinst_PROGRAMS = msiextract
+
+msiextract_CFLAGS = -w
+
+msiextract_VALAFLAGS = \
+ --enable-experimental \
+ --pkg config \
+ --pkg gio-unix-2.0 \
+ --pkg libgcab-1.0 \
+ --pkg libmsi-1.0 \
+ --pkg posix \
+ --vapidir=. \
+ $(NULL)
+
+msiextract_SOURCES = \
+ tools/msiextract.vala \
+ $(NULL)
+
+msiextract_CPPFLAGS = $(wixl_CPPFLAGS)
+msiextract_LDADD = $(wixl_LDADD)
+
# Wixl
bin_PROGRAMS += wixl