summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2013-08-13 20:11:46 +0200
committerMarc-André Lureau <marcandre.lureau@gmail.com>2013-08-13 20:51:35 +0200
commit74a2fd1c4402ccc071e91de0895b3c0a98fda031 (patch)
tree95a17f6c0502274d4aa4b6c066a331ef88261bc4 /Makefile.am
parent52f89268696fd61ae8e510d80bab3dc6424a1410 (diff)
downloadmsitools-74a2fd1c4402ccc071e91de0895b3c0a98fda031.tar.gz
msitools-74a2fd1c4402ccc071e91de0895b3c0a98fda031.tar.xz
msitools-74a2fd1c4402ccc071e91de0895b3c0a98fda031.zip
build-sys: use git.mk to generate .gitignore
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am45
1 files changed, 34 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 3e7173c..2789a51 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,8 +21,9 @@ dist_libmsiinclude_HEADERS = \
$(NULL)
AM_CFLAGS = $(WARN_CFLAGS)
-AM_CPPFLAGS = -Iinclude -I$(srcdir)/include \
- $(GLIB_CFLAGS) $(GSF_CFLAGS) $(UUID_CFLAGS) \
+AM_CPPFLAGS = \
+ -Iinclude -I$(srcdir)/include \
+ $(GLIB_CFLAGS) $(GSF_CFLAGS) $(UUID_CFLAGS) \
$(NULL)
AM_LDFLAGS = -Llibmsi
@@ -81,6 +82,10 @@ libcommon_a_VALAFLAGS = \
$(NULL)
libcommon_a_CFLAGS = -w
+common.vapi libcommon.h: libcommon.a
+
+BUILT_SOURCES = common.vapi libcommon.h
+
bin_PROGRAMS += wixl
wixl_CFLAGS = -w
@@ -126,7 +131,11 @@ wixl_LDADD = \
$(WIXL_LIBS) \
$(NULL)
-wixl_DEPENDENCIES = libmsi/libmsi.la
+# FIXME -j: automake valagen doesn't seem to wait deps:
+wixl_DEPENDENCIES = libmsi/libmsi.la common.vapi
+
+# FIXME: workaround for a vala bug
+BUILT_SOURCES += wixl.h
# Wixl-heat
@@ -172,22 +181,27 @@ clean-local:
-$(SHELL) $(srcdir)/tests/testsuite --clean
dist-hook:
- @for file in `cd $(srcdir)/tests && \
+ @for file in `cd $(srcdir)/tests && \
$(AUTOM4TE) --language=autotest --trace='AT_MSIDATA:tests/data/$$1' \
- testsuite.at`; do \
- dir=`echo "/$$file" | sed -e 's,/[^/]*$$,,'`; \
- $(MKDIR_P) "$(distdir)$$dir" || exit 1; \
- echo cp -fpR $(srcdir)/$$file "$(distdir)$$dir"; \
- cp -fpR $(srcdir)/$$file "$(distdir)$$dir" || exit 1; \
+ testsuite.at`; do \
+ dir=`echo "/$$file" | sed -e 's,/[^/]*$$,,'`; \
+ $(MKDIR_P) "$(distdir)$$dir" || exit 1; \
+ echo cp -fpR $(srcdir)/$$file "$(distdir)$$dir"; \
+ cp -fpR $(srcdir)/$$file "$(distdir)$$dir" || exit 1; \
done
@echo $(VERSION) > $(distdir)/.tarball-version
$(srcdir)/tests/testsuite: tests/testsuite.at tests/wixl.at tests/package.m4
- $(AM_V_GEN)cd $(srcdir)/tests && \
+ $(AM_V_GEN)cd $(srcdir)/tests && \
$(AUTOM4TE) --language=autotest -o testsuite.tmp testsuite.at && \
mv testsuite.tmp testsuite
+MAINTAINERCLEANFILES = \
+ $(srcdir)/tests/testsuite \
+ $(srcdir)/tests/package.m4 \
+ $(NULL)
+
EXTRA_DIST += \
$(top_srcdir)/.version \
NEWS \
@@ -197,6 +211,15 @@ EXTRA_DIST += \
msitools.doap \
$(NULL)
-BUILT_SOURCES = $(top_srcdir)/.version
+BUILT_SOURCES += $(top_srcdir)/.version
$(top_srcdir)/.version:
@echo $(VERSION) > $@-t && mv $@-t $@
+
+MAINTAINERCLEANFILES += \
+ $(GITIGNORE_MAINTAINERCLEANFILES_TOPLEVEL) \
+ $(GITIGNORE_MAINTAINERCLEANFILES_MAKEFILE_IN) \
+ $(GITIGNORE_MAINTAINERCLEANFILES_M4_LIBTOOL) \
+ m4/intltool.m4 \
+ $(NULL)
+
+-include $(top_srcdir)/git.mk