summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d87c9c2f..3578f6cf 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -44,6 +44,18 @@ set(TEST_TARGET_LIBRARIES
add_subdirectory(unittests)
if (WITH_CLIENT_TESTING)
+ find_package(socket_wrapper REQUIRED)
+ find_package(nss_wrapper REQUIRED)
+ find_program(SSHD_EXECUTABLE
+ NAME
+ sshd
+ PATHS
+ /sbin
+ /usr/sbin
+ /usr/local/sbin)
+ if (NOT SSHD_EXECUTABLE)
+ message(SEND_ERROR "Could not find sshd which is required for client testing")
+ endif()
add_subdirectory(client)
endif (WITH_CLIENT_TESTING)