summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2014-04-15 21:12:56 +0200
committerFabiano FidĂȘncio <fidencio@redhat.com>2015-10-12 13:47:09 +0200
commitcdbd2bdd3c6b191546059ab71e888d61faacca18 (patch)
tree08d9c3dd8b16a8b3bc918529783942cb5b940158 /tests/CMakeLists.txt
parent8ec46cbd42c2af7b7e1a06e3b3087e97526b558e (diff)
downloadlibssh-cdbd2bdd3c6b191546059ab71e888d61faacca18.tar.gz
libssh-cdbd2bdd3c6b191546059ab71e888d61faacca18.tar.xz
libssh-cdbd2bdd3c6b191546059ab71e888d61faacca18.zip
cmake: Search for cwrap and sshd.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d87c9c2f..3578f6cf 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -44,6 +44,18 @@ set(TEST_TARGET_LIBRARIES
add_subdirectory(unittests)
if (WITH_CLIENT_TESTING)
+ find_package(socket_wrapper REQUIRED)
+ find_package(nss_wrapper REQUIRED)
+ find_program(SSHD_EXECUTABLE
+ NAME
+ sshd
+ PATHS
+ /sbin
+ /usr/sbin
+ /usr/local/sbin)
+ if (NOT SSHD_EXECUTABLE)
+ message(SEND_ERROR "Could not find sshd which is required for client testing")
+ endif()
add_subdirectory(client)
endif (WITH_CLIENT_TESTING)