summaryrefslogtreecommitdiffstats
path: root/pki/base/native-tools/src/setpin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pki/base/native-tools/src/setpin/CMakeLists.txt')
-rw-r--r--pki/base/native-tools/src/setpin/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/pki/base/native-tools/src/setpin/CMakeLists.txt b/pki/base/native-tools/src/setpin/CMakeLists.txt
new file mode 100644
index 000000000..b32e12b22
--- /dev/null
+++ b/pki/base/native-tools/src/setpin/CMakeLists.txt
@@ -0,0 +1,43 @@
+project(setpin C)
+
+find_package(Ldap REQUIRED)
+
+set(SETPIN_PRIVATE_INCLUDE_DIRS
+ ${CMAKE_BINARY_DIR}
+ ${NSPR_INCLUDE_DIRS}
+ ${NSS_INCLUDE_DIRS}
+ ${LDAP_INCLUDE_DIRS}
+)
+
+set(SETPIN_LINK_LIBRARIES
+ ${NSPR_LIBRARIES}
+ ${NSS_LIBRARIES}
+ ${LDAP_LIBRARIES}
+)
+
+set(setpin_SRCS
+ b64.c
+ options.c
+ setpin.c
+ setpin_options.c
+)
+
+include_directories(${SETPIN_PRIVATE_INCLUDE_DIRS})
+
+add_executable(setpin ${setpin_SRCS})
+
+target_link_libraries(setpin ${SETPIN_LINK_LIBRARIES})
+
+install(
+ TARGETS setpin
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
+)
+
+install(
+ FILES
+ setpin.conf
+ DESTINATION
+ ${SHARE_INSTALL_PREFIX}/pki/native-tools/
+)