summaryrefslogtreecommitdiffstats
path: root/pki/base/native-tools/src/p7tool/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pki/base/native-tools/src/p7tool/CMakeLists.txt')
-rw-r--r--pki/base/native-tools/src/p7tool/CMakeLists.txt33
1 files changed, 0 insertions, 33 deletions
diff --git a/pki/base/native-tools/src/p7tool/CMakeLists.txt b/pki/base/native-tools/src/p7tool/CMakeLists.txt
deleted file mode 100644
index 6adfbedb7..000000000
--- a/pki/base/native-tools/src/p7tool/CMakeLists.txt
+++ /dev/null
@@ -1,33 +0,0 @@
-project(p7tool C)
-
-set(P7TOOL_PRIVATE_INCLUDE_DIRS
- ${CMAKE_BINARY_DIR}
- ${NSPR_INCLUDE_DIRS}
- ${NSS_INCLUDE_DIRS}
-)
-
-set(P7TOOL_LINK_LIBRARIES
- ${NSPR_LIBRARIES}
- ${NSS_LIBRARIES}
-)
-
-set(p7tool_SRCS
- secerror.c
- secpwd.c
- secutil.c
- pppolicy.c
- p7tool.c
-)
-
-include_directories(${P7TOOL_PRIVATE_INCLUDE_DIRS})
-
-add_executable(p7tool ${p7tool_SRCS})
-
-target_link_libraries(p7tool ${P7TOOL_LINK_LIBRARIES})
-
-install(
- TARGETS p7tool
- RUNTIME DESTINATION ${BIN_INSTALL_DIR}
- LIBRARY DESTINATION ${LIB_INSTALL_DIR}
- ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
-)