summaryrefslogtreecommitdiffstats
path: root/pki/base/native-tools/src/bulkissuance/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pki/base/native-tools/src/bulkissuance/CMakeLists.txt')
-rw-r--r--pki/base/native-tools/src/bulkissuance/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/pki/base/native-tools/src/bulkissuance/CMakeLists.txt b/pki/base/native-tools/src/bulkissuance/CMakeLists.txt
new file mode 100644
index 000000000..31df27306
--- /dev/null
+++ b/pki/base/native-tools/src/bulkissuance/CMakeLists.txt
@@ -0,0 +1,37 @@
+project(bulkissuance C)
+
+set(BULKISSUANCE_PRIVATE_INCLUDE_DIRS
+ ${CMAKE_BINARY_DIR}
+ ${NSPR_INCLUDE_DIRS}
+ ${NSS_INCLUDE_DIRS}
+)
+
+set(BULKISSUANCE_LINK_LIBRARIES
+ ${NSPR_LIBRARIES}
+ ${NSS_LIBRARIES}
+)
+
+set(bulkissuance_SRCS
+ bulkissuance.c
+ getopt.c
+)
+
+include_directories(${BULKISSUANCE_PRIVATE_INCLUDE_DIRS})
+
+add_executable(bulkissuance ${bulkissuance_SRCS})
+
+target_link_libraries(bulkissuance ${BULKISSUANCE_LINK_LIBRARIES})
+
+install(
+ TARGETS bulkissuance
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
+)
+
+install(
+ FILES
+ bulkissuance.data
+ DESTINATION
+ ${SHARE_INSTALL_PREFIX}/pki/native-tools/
+)