summaryrefslogtreecommitdiffstats
path: root/base/tps/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'base/tps/CMakeLists.txt')
-rw-r--r--base/tps/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/base/tps/CMakeLists.txt b/base/tps/CMakeLists.txt
index 96d23fefa..10c4d8efd 100644
--- a/base/tps/CMakeLists.txt
+++ b/base/tps/CMakeLists.txt
@@ -43,6 +43,19 @@ add_subdirectory(tools)
add_subdirectory(doc)
add_subdirectory(setup)
+# install systemd scripts
+install(
+ FILES
+ lib/systemd/system/pki-tpsd.target
+ lib/systemd/system/pki-tpsd@.service
+ DESTINATION
+ ${SYSTEMD_LIB_INSTALL_DIR}
+ PERMISSIONS
+ OWNER_EXECUTE OWNER_WRITE OWNER_READ
+ GROUP_EXECUTE GROUP_READ
+ WORLD_EXECUTE WORLD_READ
+)
+
# install init script
install(
FILES
@@ -206,3 +219,8 @@ install(
${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}/docroot/tps/admin/console/js
)
+install(
+ DIRECTORY
+ DESTINATION
+ ${SYSTEMD_ETC_INSTALL_DIR}/pki-tpsd.target.wants
+)