summaryrefslogtreecommitdiffstats
path: root/base/deploy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'base/deploy/CMakeLists.txt')
-rw-r--r--base/deploy/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/base/deploy/CMakeLists.txt b/base/deploy/CMakeLists.txt
index 44705818c..c7c4bd19b 100644
--- a/base/deploy/CMakeLists.txt
+++ b/base/deploy/CMakeLists.txt
@@ -23,6 +23,7 @@ set(APACHE_SUBSYSTEMS
install(
FILES
+ scripts/pkidaemon
src/pkispawn
src/pkidestroy
DESTINATION
@@ -35,6 +36,17 @@ install(
install(
FILES
+ scripts/operations
+ DESTINATION
+ ${DATA_INSTALL_DIR}/scripts/
+ PERMISSIONS
+ OWNER_EXECUTE OWNER_WRITE OWNER_READ
+ GROUP_EXECUTE GROUP_READ
+ WORLD_EXECUTE WORLD_READ
+)
+
+install(
+ FILES
config/pkideployment.cfg
config/pkislots.cfg
DESTINATION
@@ -97,8 +109,8 @@ install(
)
# install empty directories
-#install(CODE "file(MAKE_DIRECTORY \$ENV{DESTDIR}${VAR_INSTALL_DIR}/lock/pki)")
-#install(CODE "file(MAKE_DIRECTORY \$ENV{DESTDIR}${VAR_INSTALL_DIR}/run/pki)")
+install(CODE "file(MAKE_DIRECTORY \$ENV{DESTDIR}${VAR_INSTALL_DIR}/lock/pki)")
+install(CODE "file(MAKE_DIRECTORY \$ENV{DESTDIR}${VAR_INSTALL_DIR}/run/pki)")
# install subsystem directories for pkispawn and pkidestroy
foreach(PKI_SUBSYSTEM ${PKI_SUBSYSTEMS})