summaryrefslogtreecommitdiffstats
path: root/base/deploy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'base/deploy/CMakeLists.txt')
-rw-r--r--base/deploy/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/base/deploy/CMakeLists.txt b/base/deploy/CMakeLists.txt
index d63176f1a..3b1d9f583 100644
--- a/base/deploy/CMakeLists.txt
+++ b/base/deploy/CMakeLists.txt
@@ -67,6 +67,19 @@ install(
etc/
DESTINATION
${SYSCONF_INSTALL_DIR}/pki
+ PATTERN "pki.conf" EXCLUDE
+)
+
+configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/etc/pki.conf
+ ${CMAKE_CURRENT_BINARY_DIR}/etc/pki.conf
+)
+
+install(
+ FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/etc/pki.conf
+ DESTINATION
+ ${SYSCONF_INSTALL_DIR}/pki/
)
find_package(PythonInterp REQUIRED)