summaryrefslogtreecommitdiffstats
path: root/base/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'base/common/CMakeLists.txt')
-rw-r--r--base/common/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/base/common/CMakeLists.txt b/base/common/CMakeLists.txt
new file mode 100644
index 000000000..10a7cc0bb
--- /dev/null
+++ b/base/common/CMakeLists.txt
@@ -0,0 +1,16 @@
+project(common Java)
+
+install(
+ FILES
+ setup/CertServer.directory
+ setup/menu.xml
+ DESTINATION
+ ${DATA_INSTALL_DIR}/setup/
+ PERMISSIONS
+ OWNER_WRITE OWNER_READ
+ GROUP_READ
+ WORLD_READ
+)
+
+add_subdirectory(src)
+add_subdirectory(test)