summaryrefslogtreecommitdiffstats
path: root/pki/specs/pki-kra.spec
diff options
context:
space:
mode:
authormharmsen <mharmsen@c9f7a03b-bd48-0410-a16d-cbbf54688b0b>2011-09-29 22:47:22 +0000
committermharmsen <mharmsen@c9f7a03b-bd48-0410-a16d-cbbf54688b0b>2011-09-29 22:47:22 +0000
commit0b33589656656c9af3dc26feefbbf4ba9589de8b (patch)
tree06666f81151d6c5d45edcf4f644401f069761e4b /pki/specs/pki-kra.spec
parent8f8c2e5f8918b5dba1a16a5041c3f048377a1b01 (diff)
downloadpki-0b33589656656c9af3dc26feefbbf4ba9589de8b.tar.gz
pki-0b33589656656c9af3dc26feefbbf4ba9589de8b.tar.xz
pki-0b33589656656c9af3dc26feefbbf4ba9589de8b.zip
Bugzilla Bug #737761 - Update Dogtag Packages for Fedora 16
git-svn-id: svn+ssh://svn.fedorahosted.org/svn/pki/trunk@2237 c9f7a03b-bd48-0410-a16d-cbbf54688b0b
Diffstat (limited to 'pki/specs/pki-kra.spec')
-rw-r--r--pki/specs/pki-kra.spec70
1 files changed, 45 insertions, 25 deletions
diff --git a/pki/specs/pki-kra.spec b/pki/specs/pki-kra.spec
index b0a0aa9d7..41c02e762 100644
--- a/pki/specs/pki-kra.spec
+++ b/pki/specs/pki-kra.spec
@@ -1,5 +1,5 @@
Name: pki-kra
-Version: 9.0.7
+Version: 9.0.8
Release: 1%{?dist}
Summary: Certificate System - Data Recovery Manager
URL: http://pki.fedoraproject.org/
@@ -12,42 +12,49 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
BuildRequires: java-devel >= 1:1.6.0
+BuildRequires: nspr-devel
+BuildRequires: nss-devel
%if 0%{?fedora} >= 16
BuildRequires: jpackage-utils >= 0:1.7.5-10
+BuildRequires: jss >= 4.2.6-19.1
+BuildRequires: pki-common >= 9.0.15
+BuildRequires: pki-util >= 9.0.15
+BuildRequires: systemd-units
%else
BuildRequires: jpackage-utils
-%endif
BuildRequires: jss >= 4.2.6-17
-BuildRequires: nspr-devel
-BuildRequires: nss-devel
BuildRequires: pki-common
BuildRequires: pki-util
-%if 0%{?fedora} >= 16
-BuildRequires: systemd-units
%endif
Requires: java >= 1:1.6.0
-Requires: pki-common
-Requires: pki-kra-theme
-Requires: pki-selinux
+Requires: pki-kra-theme >= 9.0.0
%if 0%{?fedora} >= 16
+Requires: pki-common >= 9.0.15
+Requires: pki-selinux >= 9.0.15
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
-%else
+%elseif 0%{?fedora} >= 15
+Requires: pki-common
+Requires: pki-selinux
Requires(post): chkconfig
Requires(preun): chkconfig
Requires(preun): initscripts
Requires(postun): initscripts
-%endif
-
-%if 0%{?fedora} >= 15
# Details:
#
# * https://fedoraproject.org/wiki/Features/var-run-tmpfs
# * https://fedoraproject.org/wiki/Tmpfiles.d_packaging_draft
#
Requires: initscripts
+%else
+Requires: pki-common
+Requires: pki-selinux
+Requires(post): chkconfig
+Requires(preun): chkconfig
+Requires(preun): initscripts
+Requires(postun): initscripts
%endif
Source0: http://pki.fedoraproject.org/pki/sources/%{name}/%{name}-%{version}.tar.gz
@@ -158,19 +165,27 @@ fi
%else
%post
# Attempt to update ALL old "KRA" instances to "systemd"
-#for inst in `ls /etc/sysconfig/pki/kra`; do
-# if [ ! -e "/etc/systemd/system/pki-krad.target.wants/pki-krad@${inst}.service" ]; then
-# ln -s "/lib/systemd/system/pki-krad@.service" "/etc/systemd/system/pki-krad.target.wants/pki-krad@${inst}.service"
-# [ -e /var/lib/${inst}/${inst} ] && unlink /var/lib/${inst}/${inst}
-# ln -s /usr/sbin/tomcat6-sysd /var/lib/${inst}/${inst}
-# echo "pkicreate.systemd.servicename=pki-krad@${inst}.service" >> /var/lib/${inst}/conf/CS.cfg
-# fi
-#done
+for inst in `ls /etc/sysconfig/pki/kra`; do
+ if [ ! -e "/etc/systemd/system/pki-krad.target.wants/pki-krad@${inst}.service" ]; then
+ ln -s "/lib/systemd/system/pki-krad@.service" \
+ "/etc/systemd/system/pki-krad.target.wants/pki-krad@${inst}.service"
+ [ -L /var/lib/${inst}/${inst} ] && unlink /var/lib/${inst}/${inst}
+ ln -s /usr/sbin/tomcat6-sysd /var/lib/${inst}/${inst}
+
+ if [ -e /var/run/${inst}.pid ]; then
+ kill -9 `cat /var/run/${inst}.pid` || :
+ rm -f /var/run/${inst}.pid
+ echo "pkicreate.systemd.servicename=pki-krad@${inst}.service" >> \
+ /var/lib/${inst}/conf/CS.cfg || :
+ /bin/systemctl daemon-reload >/dev/null 2>&1 || :
+ /bin/systemctl restart pki-krad@${inst}.service || :
+ else
+ echo "pkicreate.systemd.servicename=pki-krad@${inst}.service" >> \
+ /var/lib/${inst}/conf/CS.cfg || :
+ fi
+ fi
+done
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
-# Attempt to restart ALL updated "KRA" instances
-#if [ $1 = 2 ] ; then
-# /bin/systemctl try-restart pki-krad.target >/dev/null 2>&1 || :
-#fi
%preun
if [ $1 = 0 ] ; then
@@ -214,6 +229,11 @@ fi
%changelog
+* Thu Sep 22 2011 Matthew Harmsen <mharmsen@redhat.com> 9.0.8-1
+- Bugzilla Bug #734590 - Refactor JNI libraries for Fedora 16+ . . . (mharmsen)
+- Bugzilla Bug #699809 - Convert CS to use systemd (alee)
+- Bugzilla Bug #730146 - SSL handshake picks non-FIPS ciphers in FIPS mode (cfu)
+
* Mon Sep 12 2011 Matthew Harmsen <mharmsen@redhat.com> 9.0.7-1
- Bugzilla Bug #734590 - Refactor JNI libraries for Fedora 16+ . . .
- Bugzilla Bug #699809 - Convert CS to use systemd (alee)